Kuhne MKU UP 2424 A suddenly died?!

  • Hi @ll,

    I have a Kuhne MKU UP 2424A up converter in use since February. During my /p activity from PA the converter obviously suddenly died. It does not output any power any more. The input settings were not modified. It happened just between two QSOs (or after a QSO as the next calling station could not be answered any more).

    Has anybody of the Kuhne users experienced such a problem? I heard of one case where this symtom also happend but the converter came back to life without any further action some days later.

    In my case this does not apply apparently and the converter is still dead ...

    Any hints or help much apprechiated.

    vy73 de Florian DF2ET ;(;(;(

  • df2et Hi Florian, sorry to hear about your problem with the MKU.

    Question: are all frontpanel LED's OFF or do these light up - except for the RF power?.

    In case of the 2nd situation: Once I was testing a new H2010 Ultraflex 10 coax cable with inferior N-connectors that resulted in a SWR-shutdown of my MKU2424A. If this is the case with your setup, you could try other cables/antenna or use a suitable dummyload to see if the up-converter works properly.

    Another hint is perhaps measuring the bias-current with the converter just powered 13.5VDC - no PTT - no RF drive = 135mA, with PTT - no RF drive = abt 900mA

    Also, checking for presence of a correct PTT signal could be wise.

    Good luck !!

    73 Ed PA1EW

  • Hi Ed,

    tnx for your support. I think it is not a problem with SWR as I tried various dummy loads and atennas. Also the SWR LED on the front panet should have ligted up in this case. But that did not happen. PTT works as the PTT LED turns red in case of transmissions. Besides that the SWR shutdown should be detectable using the serial terminal. But reading that also does not indicate a SWR problem.

    In fact I did return the unit yesterday and am now waiting for an information by the manufacturer. Let's see what happens.

    vy73 de Florian DF2ET

  • Switching off complete power supply sometimes will help. I have had similar problems with old A version. After update/repair to version B this problem seems to be solved.

    Switching power on and off did not help in this case. My unit has been updated/reparied to model B earlier this year. So this obviously also happens to model B units ... :(