Pluto and DATV-express

  • I am trying to get a DVBS2 TX running with Pluto.
    In general it works, but the video quality is very bad.


    PC: Win7, Intel i7 16-cores, 16GB ram

    Pluto: all hacks installed, second core activated
    Pluto connected via USB or ETH (makes no difference)

    Software: DATV express, 333 S/s

    Cam: 1920x1080p webcam


    Receiver: SF8008

    RX signal strength: 99%


    When I receive videos (333 S/s) via QO100 from other people using pluto, all looks fine, nice quality.


    When I directly (not via QO100) receive my own signal, generated by pluto, there are strong artifacts and blocks. These blocks are "pumping" every second, the picture gets very bad and then improves a bit during the next second. When objects in the video are moving, I see only blocks and extreme artifacts like the tail of a comet.


    Please can anyone post the settings of the datv-express menus, or has another idea what I could try to improve quality ?


    73, Kurt, DJ0ABR

  • thank you for answering my questions,

    Heiner, a test with 2000 kS/s worked fine too,


    For 333 kS/s:
    G0MJW : that did the trick. I reduced the input resolution to 640x480 and the picture was fine.


    An additional improvement was to change the FEC to 9/10.
    Can anybody explain what this FEC setting is doing ?

    With 1/2 I still have some blocks, with 9/10 the picture is clean.

    With some other FEC settings (i.e. 1/4) the TXbuffer fills up to 99%.

  • The FEC setting adjusts how much of the available bandwidth is used for the video and how much is used for error correction. At a setting of 3/4 three quarters of the available bandwidth is used for video and the remaining one quarter for error correction.

    The best setting for FEC depends on how strong your signal is. If you have a strong signal you need less error correction so you can increase the value and get better quality video. If you have a weak signal you will have to reduce the value to give more error correction so that people can receive you, but your video quality will also go down.

    The best combination of video resolution, bitrate and FEC is a matter of experimenting.

  • ok thanks, that makes sense. So if I choose 1/4 than only one quarter is used for video. This is why my TX buffer is filled up to 99%.

    It also explains why 9/10 gives the best results in my local transmission over only 5m distance,

  • dj0abr

    you have to adjust the TX buffer in the video codec settings drop down...

    Reduce the video bitrate twiddle in small steps... until you do not have a TX buffer overflow...

  • Yes, if the buffer fills up it is a sign that you are trying to send more data than the current settings can handle. You either need to reduce the amount of data you are feeding in or increase the rate you are sending out.