Jetson Nano and Lime SDR mini

  • GM all,

    had first success with the Jetson Nano, Lime SDR mini and the PI Version 2 cam. DVB-S2 transmit ok.


    Yesterday the LKV373A arrived, and I did all the steps from https://wiki.batc.org.uk/Jetson_Nano with success.

    Can watch the output from the LKV373A on VLC with the stream adress udp://@239.255.42.42:5004.

    So far so good.

    Now I tried to connect the LVK373A to the Jetson Nano via ethernet, and start the software from Evariste with script modified for IP input.

    Transmit of DVBS-2 carrier ok, no error message from the running script, but no video transmitted.

    What can I try? Maybe wrong ethernet connection between Jetson Nano and the LKV373A?

    I´ve no Portsdown between.

    If I change the script, the PI cam still working. Do I have to remove the PI cam hardware?

    I´ve no idea what I can try as next step... :-(


    Any hints?


    73

    Robert, DD4YR

  • Hello Mike,

    I see nothing what may be not right.

    The script output during run is:


    DVB LongFrame

    Frame Size=64800

    Net TS bitrate input should be 494429


    VideoBitrate = 295378

    VideoPeakBitrate = 324915

    DVB LongFrame

    Frame Size=64800

    Net TS bitrate input should be 494429

    Using live mode

    ffmpeg version 3.4.6-0ubuntu0.18.04.1 Copyright (c) 2000-2019 the FFmpeg developers

    built with gcc 7 (Ubuntu/Linaro 7.3.0-16ubuntu3)

    configuration: --prefix=/usr --extra-version=0ubuntu0.18.04.1 --toolchain=hardened --libdir=/usr/lib/aarch64-linux-gnu --incdir=/usr/include/aarch64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-librsvg --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared

    libavutil 55. 78.100 / 55. 78.100

    libavcodec 57.107.100 / 57.107.100

    libavformat 57. 83.100 / 57. 83.100

    libavdevice 57. 10.100 / 57. 10.100

    libavfilter 6.107.100 / 6.107.100

    libavresample 3. 7. 0 / 3. 7. 0

    libswscale 4. 8.100 / 4. 8.100

    libswresample 2. 9.100 / 2. 9.100

    libpostproc 54. 7.100 / 54. 7.100

    Reference clock 40.00 MHz

    LimeSDR-Mini Library 19.04.1-g627c82c7 Firmware 6 Gateware 1.30 Temperature 45.00

    TXLPF set to 5.000 MHz (requested 1.350 MHz [out of range])

    Filter calibrated. Filter order-4th, filter bandwidth set to 5 MHz.Real pole 1st order filter set to 2.5 MHz. Preemphasis filter not active

    TX LPF configured

    Use limemini.cal Calibration

    sample_rate: 999999.990066



    CoefBufferSize=2

    Fifo =0/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    Fifo =87720/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    Fifo =99960/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    Fifo =103020/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    ....

    and so on

  • I cant get it to work with the version I have...

    Could you may be provice me with your version of the script, where we know that it works?


    Robert

  • I thin here is shown that there must be a contact to the LVK373A

    What means the 3 lines starting at line 38


    Allocating new output: 1728x1088 (x 12), ThumbnailMode = 0

    OPENMAX: HandleNewStreamFormat: 3595: Send OMX_EventPortSettingsChanged: nFrameWidth = 1728, nFrameHeight = 1080

    Framerate set to : 30 at NvxVideoEncoderSetParameterNvMMLiteOpen : Block : BlockType = 8


    still no video ... :-(


    Robert



    I run on Nano

    DVB LongFrame

    Frame Size=64800

    Net TS bitrate input should be 661126


    VideoBitrate = 403731

    VideoPeakBitrate = 444104

    DVB LongFrame

    Frame Size=64800

    Net TS bitrate input should be 661126

    Using live mode

    ffmpeg version 3.4.6-0ubuntu0.18.04.1 Copyright (c) 2000-2019 the FFmpeg developers

    built with gcc 7 (Ubuntu/Linaro 7.3.0-16ubuntu3)

    configuration: --prefix=/usr --extra-version=0ubuntu0.18.04.1 --toolchain=hardened --libdir=/usr/lib/aarch64-linux-gnu --incdir=/usr/include/aarch64-linux-gnu --enable-gpl --disable-stripping --enable-avresample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librubberband --enable-librsvg --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libopencv --enable-libx264 --enable-shared

    libavutil 55. 78.100 / 55. 78.100

    libavcodec 57.107.100 / 57.107.100

    libavformat 57. 83.100 / 57. 83.100

    libavdevice 57. 10.100 / 57. 10.100

    libavfilter 6.107.100 / 6.107.100

    libavresample 3. 7. 0 / 3. 7. 0

    libswscale 4. 8.100 / 4. 8.100

    libswresample 2. 9.100 / 2. 9.100

    libpostproc 54. 7.100 / 54. 7.100

    Reference clock 40.00 MHz

    LimeSDR-Mini Library 19.04.1-g627c82c7 Firmware 6 Gateware 1.30 Temperature 45.00

    TXLPF set to 5.000 MHz (requested 1.350 MHz [out of range])

    NvMMLiteOpen : Block : BlockType = 261

    NVMEDIA: Reading sys.display-size : status: 6

    NvMMLiteBlockCreate : Block : BlockType = 261

    Allocating new output: 1728x1088 (x 12), ThumbnailMode = 0

    OPENMAX: HandleNewStreamFormat: 3595: Send OMX_EventPortSettingsChanged: nFrameWidth = 1728, nFrameHeight = 1080

    Framerate set to : 30 at NvxVideoEncoderSetParameterNvMMLiteOpen : Block : BlockType = 8

    ===== NVMEDIA: NVENC =====

    NvMMLiteBlockCreate : Block : BlockType = 8

    NVMEDIA: H265 : Profile : 1

    Filter calibrated. Filter order-4th, filter bandwidth set to 5 MHz.Real pole 1st order filter set to 2.5 MHz. Preemphasis filter not active

    TX LPF configured

    Use limemini.cal Calibration

    sample_rate: 999999.990066



    CoefBufferSize=2

    Fifo =0/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    Fifo =99960/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    Fifo =75480/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    Fifo =98940/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    Fifo =66300/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    Fifo =90780/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    Fifo =110160/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    Fifo =73440/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

    Fifo =96900/259080 dropped 0 underrun 0 overrun 0 Link=0.000000

  • yes, IP is correct, checked before with VLC on another PC. There the stream is working...

    Script is from Github, yes.

    Are there Video parameteres in the IPTV Server to change?


    The video settings are still the same since firmeware update and reboot.


  • No - that look OK. But need to see the next part about multicast really.


    Can I check you are using this software ? https://github.com/F5OEO/dvbsdr and you are running ./jeston_nano.sh from the scrips directory and not another script?


    Also you have:


    #Could be VIDEOSOURCE_PICAMERA, VIDEOSOURCE_USB_CAM , VIDEOSOURCE_IP

    VIDEOSOURCE=VIDEOSOURCE_IP

    VIDEOSOURCE_IP_ADRESS=239.255.42.42

    VIDEOSOURCE_IP_PORT=5004




    Mike

  • yes, with the pi camara it works fine with best quality.

    So I thohgt it´s only a small step to get signals from the LKV373A by only change the video input source....


    Robert

  • Still no success... :-(


    I cannot see the Ethernet signals from the LVK373A with wireshark on the Jetson Nano!


    Any hint how to connect the Ethernet between LVK373A and the Jetson Nano?


    Maybe direct line with crossover cable or anything else?


    Robert

  • Hello Alessio,

    tnx for the hints !


    Now, the multicast port seems to be ok, I can see activity:


    16:53:59.734156 IP 192.168.20.155.5004 > 239.255.42.42.5004: UDP, length 1316

    16:53:59.734426 IP 192.168.20.155.5004 > 239.255.42.42.5004: UDP, length 1316

    16:53:59.734678 IP 192.168.20.155.5004 > 239.255.42.42.5004: UDP, length 1316

    16:53:59.735022 IP 192.168.20.155.5004 > 239.255.42.42.5004: UDP, length 1316

    16:53:59.735258 IP 192.168.20.155.5004 > 239.255.42.42.5004: UDP, length 1316

    16:53:59.735485 IP 192.168.20.155.5004 > 239.255.42.42.5004: UDP, length 1316

    16:53:59.735749 IP 192.168.20.155.5004 > 239.255.42.42.5004: UDP, length 1316

    ^C

    6761 packets captured

    6799 packets received by filter

    15 packets dropped by kernel

    nano@nano:~$


    If I try to view with ffplay I get at least the result:


    nano@nano:~$ ffplay udp://239:255.42.42:5004

    ffplay version 4.2.1-0york0~18.04.1 Copyright (c) 2003-2019 the FFmpeg developers

    built with gcc 7 (Ubuntu/Linaro 7.4.0-1ubuntu1~18.04.1)

    configuration: --prefix=/usr --extra-version='0york0~18.04.1' --toolchain=hardened --libdir=/usr/lib/aarch64-linux-gnu --incdir=/usr/include/aarch64-linux-gnu --arch=arm64 --enable-gpl --disable-stripping --enable-avresample --disable-filter=resample --enable-avisynth --enable-gnutls --enable-ladspa --enable-libaom --enable-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libcdio --enable-libcodec2 --enable-libflite --enable-libfontconfig --enable-libfreetype --enable-libfribidi --enable-libgme --enable-libgsm --enable-libjack --enable-libmp3lame --enable-libmysofa --enable-libopenjpeg --enable-libopenmpt --enable-libopus --enable-libpulse --enable-librsvg --enable-librubberband --enable-libshine --enable-libsnappy --enable-libsoxr --enable-libspeex --enable-libssh --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libwebp --enable-libx265 --enable-libxml2 --enable-libxvid --enable-libzmq --enable-libzvbi --enable-lv2 --enable-omx --enable-openal --enable-opengl --enable-sdl2 --enable-nonfree --enable-libfdk-aac --enable-libdc1394 --enable-libdrm --enable-libiec61883 --enable-chromaprint --enable-frei0r --enable-libx264 --enable-shared

    libavutil 56. 31.100 / 56. 31.100

    libavcodec 58. 54.100 / 58. 54.100

    libavformat 58. 29.100 / 58. 29.100

    libavdevice 58. 8.100 / 58. 8.100

    libavfilter 7. 57.100 / 7. 57.100

    libavresample 4. 0. 0 / 4. 0. 0

    libswscale 5. 5.100 / 5. 5.100

    libswresample 3. 5.100 / 3. 5.100

    libpostproc 55. 5.100 / 55. 5.100

    Segmentation fault (core dumped)

    nano@nano:~$



    Segmentation fault, no Idea why :-(

    Maybe the wrong ffplayer version ?



    Robert

  • Dear Robert,


    try to launch directly jeston_nano.sh and wait. The tx doesn't start immediately, wait 15 sec. but after 20 the tx with the TS must start.


    It takes a lot of time to start, due to sync the TS. Try more times, in my case some times at the first attempt won't run.


    Anyway if something goes wrong may be the version of ffmpeg or the firmware of the lime.


    Unfortunately, I'm able to TX whith the LKV->NANO>LIME Express, but I've good results only at 2M/s. My impression is that my verison is wrong or there are other parameters spread in the pipe to regulate. For this reason I cannot give punctual informations.


    I asked to Yves HSL but he tells me to ask Evariste.


    73