SGlabs Transverter: Questions and Answers

  • Hello,


    Since couple of days my FT818 gives high SWR, I don't change anything at my setup.


    I use vox and hear my transverter going in TX and I can hear myself on the sat.


    Where do I have to look to solve the problem.


    73 - Rudi - ON7CL

  • DB2OS

    Changed the title of the thread from “FT818 - SGlabs Transverter and Amplifier - Bamatech potty” to “SGlabs Transverter: Questions and Answers”.
  • Hi,


    I use the vox option, no cable between the radio, I send 1 watt to the transverter, if I'm not mistaken, it can have 5w, so my FT818 cannot damage the internal attenuator ?


    Thanks for answer.


    73 - Rudi - ON7CL

  • I was talking about the coaxial cable between FT818 and transverter. Double check the cable or adapters if there are any. Difficult to damage the internal attenuator with only (maximum) six watts. So it is very likely that the problem is the coaxial cable or any adapters.

  • The High Swr issue was coming from a faulty rear socket on my new FT818. Even with a dummy load - 50 Ohm, I got high SWR. So I looked further to the radio, the power output was 8 to 9 watt, no chance to change the power to a low power settings, the front socket had no high swr reading, but the power issue was still there, even on HF the power was so high. Did send the 4 weeks old radio back to the shop. I hope I get a swap.

    I was lucky also, no damage to the transverter and the amplifier. But at the moment no qso's on QO-100. 73 - Rudi - ON7CL