Little mystery

  • Hello everybody.


    Please appreciate that my technical knowledge is limited and I have no microwave experience at all.


    I have been putting together a QO-100 system centered around a LimeSDR mini. The receiving part works fine. The transmitting part doesn't. The LimeSDR does transmit (checked with 145 MHz receiver) but no real power comes out of the 2.4 GHz system.


    The TX chain begins with the LimeSDR, followed by a 100 mW F1OPA amplifier, followed by an EDUP "8 watt" final and a filter finally into a dual patch.


    The EDUP amplifier has the TX modification, so when powered is permanently switched on TX.


    Since I don't have either a 2.4 GHz receiver or a power meter, my investigation is limited to measuring current drain.


    Now:


    1. F1OPA and EDUP amplifiers draw 380 mA on standby. This is entirely due to the EDUP standby current drain, as per specifications.


    2. Putting LimeSDR in TX, current draw only goes up to 410 mA.


    3. Disconnecting the EDUP from 12 v supply, current drain goes to 0 on standby. It would appear the the F1OPA standby draw is very low.


    4. Putting LimeSDR in TX with only F1OPA module connected to 12 V supply DOES NOT change the 0 current draw.


    The only conclusion I can draw is that, although the "on" led is lit, the F1OPA module is defective. The 30 mA increase in draw under TX conditions is - I think - the attempt of the EDUP circuit to amplify the minuscule power coming from the LimeSDR.


    Is there any other explanation?


    Thanks in advance.


    Pete MM0TWX

  • MM0TWX You can try to do a test without the F1OPA module just feeding the EDUP circuit and measure the current. The F1OPA module works as follows: Input,CAP,IC1,CAP,SAW-Filter,CAP,IC2,CAP,Output. You can try IC2 allown by feeling the lime signal behind the filter. Recommended for this testing is to put a 50Ohm termination at the output of the F1OPA module. Hope this helps you a bit.

  • Hi Pete.
    Try powering the F1OPA module alone. Does it draw power from the supply? I assume it does not have a pin that you ground to transmit.
    I've just looked at the website and I can't see much detail of the circuit, but it looks like 2 MMIC amplifiers with a switched mode supply regulator. Try to have a look if there is any voltage on the MMIC amplifier supply. - Not at the devices but on the PSU supply side of the RF choke in the feed.


    FYI
    I note that the Lime produces about 1mW at 2.4G and the F1OPA amplifier has a spec of -9dBm input for 100mW output.


    This means 2 things.
    1) The lime can overdrive the amplifier by 9dB.
    2) If the maximum output is 100mW, then that is probably not enough to get full power from the WiFi amplifier. My one needs 175mW for max linear output.

    If you wanted to have a chat on the phone about it, just let me know - g0mrf'at'aol.com

    Good luck. - David

  • I'm using a LimeMini with SDR Console and when I recently updated the software my output power dropped right off by 10 or more dB. As I'm not transmitting that often I didn't immediately connect the two things and spent a while looking for hardware problems. Eventually it turned out that the wrong transmit output was selected in SDR Console and going back to TxAnt: Band1 restored my power level.


    73 Chris G4SDG

  • @G0MRF The F1OPA module alone draws 89 mA. When switching on TX on LimeSDR and gradually increasing drive, nothing happens until about 50% drive, and then current draw from F1OPA goes DOWN (!), 70 mA at full drive.


    G4SDG . Thank you for the heads up. The Console is a great piece of softwre, but can be a pain to use (mine freezes two or three times per session anyway...). Concerning TX power, how will I be able to tell, not having a power meter of any sort for 2.4? Please remember I am using a LimeSDR mini, which only has one antenna connection for TX and one for receive. TX ant does not seem configurable.

  • Hello Pete, I would consider to buy a cheap "chinese power meter" with some attenuators and/or a directional coupler.

    If you have a small dummyload that coupler is not necessary but is maybe very practical for future in-line measurements.


    See other topic "chinese power meter".


    I bought one and (if calibrated for 1 frequency like 2400 MHz) it is a very useful meter. As i see that you don't have possibilities to calibrate it you can still use it with for example a 50 dB sma attenuator in series.

    In that case you cannot tell the exact amount of power but at least you can see if power goes out!

    I saw the meter for 40 euro at Passion radio in France so no need to wait till the Corona virus in China is gone.

  • Regarding SDR Console and the LimeSDR-Mini, I don't understand why changing the TX Antenna actually changes the output level when there's only one transmit port but it does. I'm using the latest Console software version. I checked my setup with a power meter yesterday and Band 2 is 11.5dB lower than Band 1. Selecting Auto did give the correct output.


    73 Chris G4SDG