Cannot receive the DATV signal anymore

  • IK8OZV Enzo look here:

    The VCC of the display to the VCC of the Minitiouner Pro2 Connector JP3

    The DATA of the display to the SDA of the Minitiouner Pro2 Connector JP3

    The TC/CLK of the display to the SCL of the Minitiouner Pro2 Connector JP3 that PIN I mean

    The GND of the display to the GND of the Minitiouner Pro2 Connector JP3

  • IK8OZV Enzo do the following please:

    1. disconnect display and power from minitiouner. Collect the OHM values on JP3 between SDA to GND and Vcc. The same please do with SCL to GND amd VCC.

    2. Do the same with the display as writen above.

    then we can continue.

    You can also look on the SCL and SDA lines while the display is connected and the minitiouner is under power with an ozilloscope.

    I expect you see a difference.

    Also you can read the values of the two resistors on the board which are right of JP3. theire values should be the same.

  • IK8OZV Enzo I just checked my two boards and two displays.

    On the displays SDA and SCL to GND or VCC minimum around 500KOhm so no pull up resistor on the display board.

    JP3 on my boards:

    Between GND and SDA or SCL nothing to measure.

    Between VCC and SDA I see the 3.38 KOhm

    Between VCC and SCL I see the 5.74 KOhm

    My conclusion is your board should be ok and it looks the fault is on the display board.

  • I don't know this specific problem,

    but I2C problems when connecting external components (like displays) happen frequently.

    What I would try is to solder 3,3kOhm resistors between Vcc and SDA, and also Vcc and SCL, directly to the connector on the display.

    This makes the I2C lines a little faster, maybe it helps.

    vy 73, Kurt