Pluto mit LAN Verbindung

  • Hallo Ulrich, Volker,


    Freut mich zu lesen, dass sich bei Volker das Problem erledigt hat und Ulrich hat auch eine Lösung.


    Bei mir war es ziemlich sicher die 7490, resp. die nicht oder nicht korrekt funkionierende Flusskontrolle, zumindest funktioniert sie nicht bei 1GB/s. Vielleicht schaue ich mir das mal bei 100MB/s an - Danke Ulrich für die Anregung.

    Ich bin darauf gekommen, da ich einen Netgear Managed Switch in der Leitung hatte, bei dem die Flusskontrolle deaktiviert war. Nachdem ich sie im Switch aktiviert habe, lief es zusammen mit der Fritzbox schon besser. Der Einsatz eines Switches mit großem Puffer hat auch geholfen. Richtig fehlerfrei (schön in Wireshark zu sehen) ging es aber erst, nachdem die Fritzbox nicht mehr im Spiel war. Sie hängt bei mir nur noch für den DSL-Zugang mit einer Leitung an einem Switch.

    Mit kleiner Bandbreite und wenig weiterem Traffic im LAN sollte der Pluto auch an der 100MB/s Leitung laufen, bei 3 MHz Bandbreite sind es aber dann schon 100MB/s pro Richtung.


    Ohne TX-Aussetzer macht der Pluto definitiv mehr Spass auf QO-100 :)


    73 Jean

  • Hallo nochmal,
    Leider hat sich mein Problem damit nicht wirklich erledigt.

    Denn meine "Verkabelung" lässt es nicht dauerhaft zu den Pluto direkt am gleichen Switch laufen zu lassen wie den PC.

    Sonst müsste ich immer ein LAN-Kabel quer durchs Wohnzimmer legen wenn ich Betrieb machen will.

    Das wird der XYL eher nicht so gefallen. Den Workaround mit den 100Mbit/s werd ich mal versuchen aber ich will eigentlich die Anbindung des grossen Switches im Wohnzimmer nur Ungern dauerhaft auf 100Mbit/s begrenzen. Da hängt dann auch noch eine WLAN Box dran die alle mobilen Geräte mit WLAN versorgt. Evtl. ist das dann irgendwie zuviel Action für die 7490??
    Ich werde das auf alle Fälle mal weiterverfolgen und testen. Mein QO-100 Setup ist auch noch absolut am Anfangsstadium mit komplett fliegendem Aufbau am Balkon (ausser der 85cm Spiegel der bleibt montiert und dient gleichzeitig auch noch als TV Empfangsanlage für Astra 19,2 und Hotbird auf 13 (beide schielend) . Die LAN-Dose nahe der Balkontür geht halt nicht zum grossen Switch sondern zur DSL FritzBox. Im Moment muss ich das Setup immer wieder "neu" aufbauen.
    Natürlich hab ich mit QRL, XYL und den Kids auch noch par andere Sachen am laufen, hi.
    Aber ich werde mal ein par verschieden Sachen ausprobieren und dann wieder berichten.
    Wichtig war erstmal zu wissen das es wirklich am Netzwerk liegt. Hatte da bisher ansich keine Probleme mit anderen "Softwaren".
    Wer neue Erkenntnisse hat gerne auch hier wieder reinschreiben...


    73 Volker

  • Du könntest versuchen einen "100MBit/s-Y-Verteiler" davor zu schalten. Damit kannst Du die beiden Adernpaare, die für 1GB/s benötigt werden abhängen. Beim Aushandeln der Verbindung müsste dann auf 100MBit/s heruntergeschaltet werden. Alternativ ein Kabel crimpen bei dem lediglich die beiden 100MBit/s Adernpaare (1,2,3,6 siehe https://www.elektronik-kompendium.de/sites/net/0510151.htm) aufgelegt sind.


    73, Thorsten

  • Guten Morgen Zusammen,

    ich habe noch mal darüber nachgedacht und bin zu dem Entschluss gekommen das es kein Problem ist die Datenrate im Router auf 100Mb/s zu reduzieren. Also alle Ports gleich einzustellen auf 100Mb. Denn wer hat schon eine Internetrate über 100Mb. Es ist also keine Einschränkung zwischen PC und Router. Ich habe heute Morgen noch mal getestet und es geht alles einwandfrei.

    Selbst wenn man einen USB/LAN-Adapter hätte würde es nicht gehen. Denn erstens müsste der Chip im LAN-ADAPTER vom Pluto unterstützt werden und zweiten kann der Pluto keine 1Gb.

    Die ganze Sache hat noch den Vorteil das der Router nicht volle Pulle läuft. Bei 1Gb läuft der Router im „Power Mode“ und bei 100Mb im „Green Mode“, wo er weniger Strom braucht.


    73 DL3ED Ulrich

  • Hallo Volker,


    Du musst kein Kabel quer durch die Wohnung legen. Es reicht aus, einen kleinen Switch neben die Fritzbox zu hängen und diesen statt dem Switch in der Fritzbox zu nutzen.

    Auf dem Weg vom PC zum Pluto habe ich zwei oder drei Switches, PC und Pluto müssen nicht an einem Switch hängen.


    73 Jean

  • Hallo Ulrich,


    Die Datenrate zum Internet ist ein anderes Thema als die Datenrate im hausinternen LAN. Ein paar Nutzer im Haus, ein NAS fürs Backup und schon werden selbst 1GB/s im LAN knapp.


    Mit 100MBit/s am Pluto schaffst du 1.2 bis 1.5 MByte Bandbreite im Duplexbetrieb. Bei der maximalen Bandbreite, die von der SDR Console unterstützt wird, gehen 200MBit/s über die Leitung. Die schafft der Pluto trotz USB2 mit einem GBit LAN-Adapter.


    73 Jean

  • Hallo zusammen,

    so ich hab wieder getestet.
    Selbst wenn ich bei mir alle Anschlüsse an der FB auf 100Mbit/s stelle tritt das Problem bei mir auf.

    (PC ist trotzdem mit 1Gb/s an den Switch verbunden nur dieser dann mit 100Mbit/s an die FB).

    Anscheinend hab ich aber eh noch ein kleines Kabelproblem mit der Verbindung vom Hauptswitch zur FB (leider nur ein CAT5 Kabel).

    Das steht aber auf einem anderen Blatt.

    Hab nun einfach mal nen ganz einfach 5-port Switch (100Mbit/s) noch dazwischen gemacht sodass die Pluto Verbindung eben nur über die 2 Switche geht und nicht über die FritzBox. Tja was soll ich sagen das funktioniert ohne Probleme. Man kann es auch wirklich an den Buffer Zeiten in der SDR Console (Radio Fenster) sehen. Mit FB-Switch gehen die manchmal bis auf 900ms hoch.

    Mit den 2 Switchen nun nur noch auf 150ms maximal 300ms und ich konnte keine Aussetzer bemerken.
    mit 550khz hab ich ca. 19Mbit/s Download vom Pluto und beim Senden im Upload auch noch 19Mbit/s zusätzlich (Full Duplex). Ist also schon nicht ganz ohne was da durch die Leitung rauscht an Bandbreite.

    Der Fehler kommt definitiv vom FritzBox Switch.

  • Hallo zusammen,


    Noch ein kleiner Nachtrag: Es hat noch niemand gefragt, warum die Probleme eigentlich nur beim Senden und nicht auch beim Empfang auftreten. Mit der Fritzbox als Switch klappt bei mir der Empfang bei jeder Bandbreite, auch bei 6MHz, was etwa 200MBit/s auf der Leitung entspricht. Beim Senden hingegen treten die Probleme bei jeder Bandbreite auf.



    Nun, die Antwort liefert ein Blick mit Wireshark: Während der Pluto immer kleine TCP Pakete sendet, schickt die SDR Console zumindest auf meinem Windows10 PC TCP Pakete mit fast 64k zum Pluto. Diese kann die Fritzbox auf die Dauer nicht korrekt handhaben, während die Switches keine Probleme damit haben, wenn die Flusskontrolle aktiv ist. Der Pluto beantwortet diese mit einer TCP Window von ca. 20k, er kann also mit größeren TCP Paketen umgehen.



    73 Jean

  • Hallo Herbert,


    Danke für den Hinweis, ich hätte das klarer ausdrücken sollen. Es war hier im Thread immer die Rede von der 7490, wie es bei anderen Fritzboxen aussieht. weiß ich nicht. Dafür kenne ich weitere OMs, die mit der 7490 das beschriebene Problem hatten.

    Natürlich spielt auch der PC eine Rolle resp. die Konfiguration der Netzwerkkarte. Sendet diese nur Standard TCP Paketlängen, dann dürfte es ebenfalls keine Probleme geben.


    73 Jean

  • Sollte man vielleicht Simon Brown selber auf diesen "Effekt" aufmerksam machen das er das auf seiner SDRC Page mit angibt? Als mögliche Probleme bei "Sendeunterbrechungen"? Da hatte Ich nämlich natürlich als erstes nach "Abhilfe" Ausschau gehalten. Deswegen auch die anderen Tests mit anderen Spannungsversorgungen Bandbreite usw...


    73 de

    Volker

  • Das mit den 64K Paketen stimmt so nicht ganz, auf dem Ethernet werden Typischer Weise eine MTU von 1500 verwendet, wenn die Geräte Jumbo-Frames unterstützen, die Fritzbox tut es nicht, sind es ca 9000.


    Das Du 64K grossen Pakete im Wireshark siehst liegt an dem TCP offload, dabei werden größere Packete vom Betriebssystem an die Netzwerkkarte gegeben und auf dieser werden die dann in die max erlaubten Paketgrössen zerlegt, da Wireshark vor der Zerlegung eingreift siehst Du die 64K grossen Pakete. Wenn du die selbe TCP Session auf dem Weg zum Pluto an einer anderen Stelle anschauen könntest würdest du nur Pakete mit einer maximalen Grösse von 1500 sehen.


    Aber Problem mit Paketverlust können auftreten wenn Du von einem Gerät mit hoher zu einem mit niedriger Bandbreite sendest. Dein PC schickt die Daten mit 1GB/s raus bis er nichts mehr zu senden hat, der Pluto kann sie aber nicht so schnell abnehmen nach einer Zeit kann es dann passieren das die Buffer der beteiligten Netzwerkgeräte voll laufen und diese dann Pakete wegwerfen. Das kann man mit der oben genannten Flußkontrolle umgehen, dann kann das Empfangende Gerät dem Sender sagen das er langsamer machen soll bzw eine Pause machen soll.


    Aber werden die RX/TX infos zwischen Pluto und PC wirklich als TCP gesendet??? Habe mir noch keine Daten zw. PC und Pluto angesehen, hätte aber gedacht das diese als Realtime Daten (RTP ggf UDP) gesendet werden.

  • Das hört sich logisch an was Ihr beide da schreibt. Danke erst mal für die Erklärung. Der Empfangfall geht logischer weise 100Mb nach 1Gb. Der Sendefall ja logischer weise nicht 1Gb nach 100Mb. Deshalb gehts bei mir wenn ich beides auf 100Mb gestellt habe.

    Jetzt brauchen wir einen Spezialisten der weis wie man die Flusskontrolle bei der FritzBox 7490 in den Griff bekommt.

    Vielleicht ist es auch ein Problem mit dem Händling im Pluto.

    73 Ulrich

  • Ganz einfach, die Fritzbox nur noch als Router benutzen und das LAN mit einem vernünftigen Switch machen ;-)


    Habe mich mit der Fritzbox nie in der Tiefe beschäftigt, aber wenn sie keine Flußkontrolle unterstützt dann lässt sich da auch nichts in den Griff bekommen. Dann hilft nur austauschen bzw den Teil auslagern. Ich nutze die Fritzbox nur noch als DSL Router und für die Telefon sachen. Das LAN und WLAN mache ich damit schon lange nicht mehr. Hat bei mir aber den Grund das ich ein paar Anforderungen hatte die die Fritzbox nicht kann.

  • So ich habe es nun genau so gemacht.

    2 x 1Gbit/s Switch für die die internen Sachen und nur noch ein Kabel vom kleinen Gbit/s Switch zur Fritz Box (auch mit 1Gb/s).

    Jetzt funktioniert die Verbindung Störungsfrei mit dem Pluto.

    Mittlerweile kosten die Gbit Sachen ja nicht mehr viel.

    73 de

    Volker

  • Da ich auch sendeseitige Aussetzer unter Anbindung des Adalm-Pluto an den PC mittels Ethernet hatte, habe ich erfolgreich folgendes ausprobiert:


    Anpassung des TX-Buffers in der sdr-console.


    Transmit -> Options -> Pluto-SDR Network -> Radio Configuration


    Dort habe ich den Parameter für Transmit auf 50ms reduziert.


    Gruß


    Peter (DG9FFM)

  • Habe so gut wie alle Buffer Einstellungen probiert - mit keiner Einstellung brachte ich über die Fritz Box eine Unterbrechungsfreie Sendung auf die Reihe. Die Zeiten und Häufigkeit hat sich dadurch geändert aber weg war es nie.

    Erst seit dem ich die FB als Switch bei der Verbindung rausgenommen habe funktioniert es mit allen Buffer Einstellungen ohne Probleme.

    Auf die Buffer Einstellungen weist ja auch Simon Brown auf seiner Seite hin deswegen habe ich das natürlich auch als erstes versucht.


    73 de

    Volker