Pluto can't be accessed any more

  • during a recent firmware update V0.31 to V0.32 i obviously managed to "kill" my pluto:

    when i connect it via usb to computer one can hear the wellknown dütdidledüt, but i'cant communicate any longer via this usb-port (i usually did it with putty and a ssh-connection through the ip address .

    the program console for qo-100-operation doesn't recognize it any more as well. where the pc shows normally the pluto - drive, it shows "usb download gadget auswerfen" instead.

    can anybody tell me if it is definitely dead or could it be brought back to life again? if yes how and in a first place who could help me with that since i'm only a stupid operator of this device.

    i'm gratefull for any help.

    wolfgang matti (dl5tp)

  • ciao aveva un amico lo stesso problema se non dai comando Plutone e la luce blu fissa ... !!! non è vivo!!! è necessario eseguire una cartella c:\plutone remota creare la cartella c:\plutone all'interno di questo programma c:\pluto tipo c:\plutone\UPDATE.bat uboot-env.dfu dopo lo stesso sistema c:\pluto\UPDATE.bat pluto.dfu dopo aver fatto attendere i due LED lampeggiare ... controllare con Putty, tutto è andato bene e dato vita Plutone

    73 Tony Ik1hgi

    When your adalm pluto goes in a non recognized usb condition in your pc. this will put him again in a live condition .
    73 de on7ndr

    adalm pluto DFU - YouTube

  • I met the same problem after firmware updating, but in my case everything is more complicated . As described above, I tried to switch the device to the DFU mode, LED's show me that the device is in DFU mode (LED1 is constantly ON), but windows device manager still says "Unknown USB device(Device descriptor request failed)", and of course I did not find the device on the network. Using USB-COM adapter i connected to JTAGUART and saw the following:

    U-Boot PlutoSDR v0.20-PlutoSDR-00053-g89d0754 (May 28 2019 - 19:24:22 -0700)

    I2C: ready

    DRAM: ECC disabled 512 MiB

    SF: Detected N25Q256A with page size 256 Bytes, erase size 4 KiB, total 32 MiB

    In: serial@e0001000

    Out: serial@e0001000

    Err: serial@e0001000

    Model: Zynq Pluto SDR Board

    Hit any key to stop autoboot: 0

    Unknown command 'bootp' - try 'help'

    Wrong Image Format for bootm command

    ERROR: can't get kernel image!


    I tried to find out what was wrong with the USB port, I got the following:

    Pluto> usb info

    USB is stopped. Please issue 'usb start' first.

    Pluto> usb start

    starting USB...

    USB0: ULPI request timed out

    zynq ULPI viewport init failed

    lowlevel init failed

    USB1: usb1 wrong num MIO: 0, Index 1

    lowlevel init failed

    USB error: all controllers failed lowlevel init


    I don't think the port has burned out. I think I made a mistake when updating firmware. How can I restore firmware using JTAGUART?