Adalm-Pluto Rev D

  • Robert,

    the pluto.php from 0303 has a lot of bugs who shows same failures...I Think its not the Revision of Pluto....

    Actually I seem to have similar issue with earlier release too from Evariste. I would guess that the rev C(D) seems to be not 100% compatible with the very popular F5OEO firmware. I guess. I can not proof it. I ordered few brand new Plutos. If they are rev C then I can do the tests. Do you have a rev C that works fine with F5OEO code?

    73 de Béla HA4BM

  • Hello

    no Rev C here

    But I had the experience, that 0303 and also 2603 corrupted all settings here.

    Also if I flashed back to earlier versions. I had to delete the browser cashes and restart for new settings....

  • DB2OS

    Changed the title of the thread from “Adalm-Pluto Revision C” to “Adalm-Pluto Rev D”.
  • Hello Muhammed,

    if you have a rev D version then I recommend to inject the reference signal from an external source. You then do not need to change the board (you can leave the existing TCXO on the board). The rev D board does have a reference frequency input jack on the board. It is recommended to use 40 MHz as the reference. 10 Mhz might work but phase noise will be worse and possibly also spurious emissions.

    Kind regards


  • Hi Muhammad,

    this module can deliver 40 MHz, you have to use "4X". The output level should be reduced with a 3dB attenuator.

    Here you find the code for external clock:

    But when you intend to receive only, you can synchronize SDR console with the middle beacon. I use a LNB with crystal oscillator, not stabilized, and it works fine.

    Best regards,


  • Ok thank u ddius

    What about this given pic ocxo ix this work . It printed from back side some kind of multiplication. And is any coding required in putty for external clk

    Hi Muhammad.

    This link below have some info about this module (use ICS512 or NB3N502):



    Sandro Ribeiro

  • Hello Irfan,

    Please contact me on my PM here or on QRZ.COM. I am using the same setup as yours. I will solve all your legal/technical problems. Transmitting on QO-100 without a proper ham radio licence isseud by PTA is serious offence here in AP land. AP2AUR, AP2HA and myself at Pakistan Amateur Radio Society (PARS)can help you getting a licence.


  • Hi,

    has someone tested the connections TX2 and RX2 in Rev D and if so, how and with what software?

    AD writes:

    The 2nd Rx / Tx channel internal to the rev D is not test during production test. If it works - bonus! If it doesn't work; Pluto is only advertised as a 1 Rx, 1 Tx radio, and that is guaranteed / production tested on each unit - and that is what you received.

    vy 73 de Rolf -DJ7TH- QTH Schwanau JN38VI

    Edited 2 times, last by DJ7TH ().

  • Benötigt die REV C/D keine weiteren Modifikationen, wie z.B die USB Mod?

    Grundsätzlich nicht.

    Die USB Modifikation ist nur notwendig wenn die Masse / Erdungsverhältnisse am Aufstellort unsauber oder undefiniert sind.

    Die von Analog Devices realisierte Trennung der Potentiale ist ja als Schutz für das Gerät gedacht ...

  • Hello

    Although I succeeded in activating the external clock input to use the 40 Mhz signal from a Leo Bodnar GPSDO, I am struggling in doing the same for injecting 25 Mhz instead.

    I used the following command:

    fw_setenv ad936x_ext_refclk ‘<25000000>’

    followed by

    fw_setenv xo_correction ‘<25000000>’

    Is this the correct way?

    Second issue

    When using the fw_setenv command, I made a typing mistake in the arguments so that I get the following now when using fw_printenv






    How can I delete the wron entry: ad936x_ext_refclck=<2500000>

    Enjoy the Sunday


  • Hi all,

    the thread is pretty old but maybe I still can help someone who comes across the same questions when set up a new station with Adalm Pluto Rev D (printed Rev C at the back of the box):

    If you want to feed the new Pluto with an external clock, just connect a u.FL cable/plug to the CLK_IN socket as described above.

    Then you just need to change 2 uboot environment variables:


    fw_setenv refclk_source external


    fw_setenv ad936x_ext_refclk_override <any_clock_you_want_to_have_in_Hz>

    and if you made a typo and created a wrong env variable, just delete it with the fw_setenv command leaving the argument blank,

    for example :

    fw_setenv sometypoinvar

    (no argument after the variable name !)

    Thats it.

    Have fun !


  • Hi

    I have used SDR console and a Pluto rev D together with a BullsEye LNB locked to the mid beacon for some time and it works perfect. Now I plan to use the pluto for TX also so I have connected a LeoBodnar GPSDO to the CLK IN socket. I have changed the env variables according to the post above. But when I connect SDR console the frequencies of the low and high beacon is not correct after locking to the mid beacon, The entire spectrum is compressed and the audio is bad. I have not changed any settings in SDR console. I attach a print screen showing the spectrum with internal and external clock. Any idea about a solution would be appreciated.

    73 de mike

  • HI agn

    I reply to myself, I solved the problem but it can be of interest for others so I leave the post. The problem was that the clocksignal from the Leo Bodnar GPSDO was to strong, I attached a 6 dB attenuator between the GPSDO and the PLUTO input, and all is behaving normal again.

    73 de mike

  • Hello

    My old Pluto failed and I have bought a new one ver. D for DigiKey. I have a problem I can not solve though I spend a lot of time on the new device. Looking for ideas...

    I updated firmware to 0.34 version.

    I made sucesfully typical operations:

    fw_setenv attr_name compatible

    fw_setenv attr_val ad9364

    fw_setenv maxcpus

    I switched the clock to external, as I have precision 40MHz source, used succesfully with previous Pluto:

    fw_setenv refclk_source external

    Then I set its frquency:

    fw_setenv ad936x_ext_refclk "<40000000>"

    After rebooting Pluto the result was not good - the receiver frequency was shifted about 9.6 kHz (ie. beacons), and transmit frequency was not aligned with RX frequency. I want to add that I use 25 MHz clock for LNB from the same 10 MHz source as for 40MHz, and with old Pluto it worked perfect.

    After checking the parameter ad936x_ext_refclk I found:

    # fw_printenv ad936x_ext_refclk

    ad936x_ext_refclk=<39999804> !!!!

    I set again fw_setenv ad936x_ext_refclk "<40000000>". Then checked:

    # fw_printenv ad936x_ext_refclk


    Good! But not really. After Pluto rebooting I have got again

    # fw_printenv ad936x_ext_refclk


    I checked many options as:

    fw_setenv ad936x_ext_refclk '<40000000>'

    fw_setenv ad936x_ext_refclk 40000000

    fw_setenv ad936x_ext_refclk_override '<40000000>'

    fw_setenv xo_correction 40000000

    After pluto-reboot reset the value of ad936x_ext_refclk alwys was coming back to <39999804>

    It looks that this idiotic value is factory set and the change is blocked. I don't know why!

    I'm not very skilled in programing, work only under Windows.

    Any idea how to solve the problem?

    Miro SP5GNI