HS-Modem

  • It works!

    Partially..

    The skimmer does not display data despite several cq calls. Maybe it is not yet operational.

    Hi Martin,

    Yes - the team is still working on it, the CW skimmer and WB spectrum should be working soon.

    The beacon frequency will also be shifted to .995 MHz on the border of the guard band and transponder mix mode.

    73 de Peter

  • Just wanna confirm that the HSModem Beacon is working.


    Received with LimeSDR and Pluto, with SDRAngel and SDRConsole with VAC and VB-audio-cable under Kali-Linux and Win10Pro.


    I had to select: 7200 8APSK BW:2700 Hz (QO-100 SDR) - then the "RX sync" went instant green and several moments (minutes) later the amsat_X.blt appeared under File / RX. Fex minutes later, the next amsat_X.blt


    Maybe now more using the software.


    vy 73

    Sandor

    DM4DS

  • Auf dem Goonhilly Web-SDR sehe ich die Bake auf 10489.990 MHz. Ist das nun die endgültige QRG und .980 oder 995 ein typo ?

    Alles noch im Testbetrieb und der Sonntag war für die Jungs vor Ort (Mario und Jens) auch zu schnell vorbei. ;-)

    .995 MHz (Mittenfrequenz) soll die engültige Frequenz werden...

  • Thanks - Yes, there is more to come.. it should be easy to add more bulletins and so on. I'm sure Kurt DJ0ABR has a lot of good ideas..

    Currently the MM beacon is off, but will be back quickly..

  • Umzug der MM-Bake offenbar erfolgreich.

    10489.993,5 = zero beat, Mittenfrequenz = 995


    Narrow Band Transponder Activity: OK

    Wide Band Transponder Activity: OK

    DX-Cluster Messages: OK

    CW Skimmer: Keine Ausgabe.

    Amsat Bulletin Text-Anzeige: OK



    Setup: Win7 32bit, sdr-console, VB-Cable, HSModem, Firefox


    73, Martin

  • Hello Forum,


    some OMs and me included, experienced more or less the same problem.

    The software is running, all works like it should, hours / sometimes days. BUT sometimes only minutes, then the "DOS box" closes and the "GUI" can´t decode any longer but is still running. You can click everything, change settings etc.


    So it looks like only the "Modem" part is closing, no automated restart, and while the GUI receives no data, it can´t do its magic.


    Have you experienced the same?

    Maybe you can offer a solution?


    Is there a debug mode we can start to "see" what causes the modem crash? Found nothing in the wiki.


    Thanks for help.

    Sandor

  • Is there a debug mode we can start to "see" what causes the modem crash? Found nothing in the wiki.

    DM4DS Can you start it from the command line in the Terminal under windows10?

    Edit: Sorry, just noticed that a DOS BOX opens and shows status messages under windows as well.


    Some Observations when running under Linux:

    hsmodem freezes, when i try to open Firefox by clicking on "Open received HTML file".


    Does not freeze when i go to the folder containing the html file, right click and choose Firefox to open. But will not show any data in the browser. Does not even display "Offline" in red.


    Does not show errors in the Terminal in both cases.


    Works normal when i go to the folder containing the html file, right click and choose Chromium or Slimjet (a fork of Firefox) to open. Will show data in the browser. Displays "OFFLINE " in red and will change to "CONNECTED to local HSmodem" in a second or two.


    I will try later to set the default browser to either Chromium or slimjet and click "Open received html file " to see what happens.

    Will report ASAP.


    73, Martin

  • on my machine, using latest WIN10 version, latest Firefox browser and VB Audio Cable, the HSMODEM worked the whole day without any interruptions or crashing..


    Watch the Debug Window (DO NOT CLOSE)



    Example settings for BATV WebSDR: the Speaker Output must be routed to the CABLE input (VB-Audio Virtual Cable and the SSB bandwidth should be large enough, the HSMODEM has it's own filter. Any noise filter must be turned off! The same way it should work with SDR-Console or any radio connected to a sound card.


    Configure the Modem Speed [bit/s] to 7200 8APSK BW: 2700 Hz (QO-100 SDR) and make sure your audio level is within the red box of the Tuning Window. Tune the frequency on your receiver, so that the small reference tone peak is on the Reference marker.



    Setup Window:


    once you have received all initial files, you can click Open received HTML file and you should see the live view.



    and voila:



    enjoy!

    73s Peter

  • Hi,


    on last Sunday I have discovered the permanent digital signal just below of the Upper Beacon on QO-100. But I could not determine the mode. I have had some idea that it could be a mode of HS Modem. Using Peter's hints above today I managed pretty fast to decode the signal. All is working at its best. I use SDR Console serving a SDRPlay RSP1, Bulleseye LNB, 80cm offset dish and VB-Audio VoiceMeeter to get the audio into the modem application.


    Thanks Peter for that helping hint.


    73 Peter
    Heustenstamm, JO40JB

  • Hello Peter,


    we do exactly what you described and yes sometimes it runs for days. sometimes only a few minutes and i sound like a vinyl, I am not alone.


    the "debug" window, i call "DOS Box" or the "modem" . This one closes without error, schwups, just gone.

    Then the GUI receives no data and idles.


    Is there a LOG file I can enable to see what happens before it closes?

  • Today I accidentally discovered the HS signal on .995 and after some searching I found the "cause" and then immediately installed the HsModem. Thanks to the detailed wiki info I was able to decode some texts, but after about 30 minutes the modem software crashed (see hard copy). Each restart ended with the Visual Studio 2010 error message.
    The software crashed after seeing the message "1 user logged in" in the modem window. (see picture #2)