How to get TX working on Adalm Pluto over Ethernet.

  • Hy i bought an Adalm Pluto and i played around with it using SDRAngel on Linux.

    I modified it connekting GND and PGND. (It helped :))

    When i connect it directly (over usb) to my pc everything works just fine.

    But when i connect a usb ethernet adapter to it, rx works fine. But when i tx the signal gets choped up really bad. (I mainly tested using the 1khz test signal and the cw generator from SDRAngel and my yaesu ft817.)

    The usb network adapter is connected to a fiber converter that is connected to my switch. The fiber converter it self has no configuration at all. On the switch i set everything to auto and i had flow controll enabled and disabled. I also tried to fix the speed to 100M. Nothing fixed this problem. I also tried a prebuild SDRAngel on Windows same result.

    The strange thing is RX Works, The network runs just fine(No bandwith problems seen on the switch).

    73, OE9BLV

  • Ok i found out that i lose Samples but i am not shure why:

    2021-05-16 23:50:54.776 (C) SampleSinkFifo::write: 19 messages dropped

    2021-05-16 23:50:54.776 (C) SampleSinkFifo::write: overflow - dropping 16384 samples

  • that sounds like the same problem as we or I already had here.
    Pluto mit LAN Verbindung

    Can you try it without this fibre converter?

    Possibly there are also problems with the package sizes.

    However, I thought that only affects the SDR console.

    And in any case, limit the bandwidth of the Pluto to 550KHz when starting. That saves a lot of bandwidth.
    Im not sure if it possible via SDRAngel....

    73 Volker