QO-100 Linux SDR Transceiver

  • Guten Morgen Jens,

    das Probem fängt mit dem ersten Befehl an, Datei oder Verzeichnis nicht gefunden.

    In welchen Verzeichnis muss man sein um diesen Befehl zu geben???

    Mit lsusb wird der USB-Stick als, Generalplus Technology Inc. angezeigt. Kann man mit USB rein, raus reproduzieren.


    Gruß Ulrich

  • Moin.

    Das Verzeichnis ist unwichtig, du musst nur das Kommando exakt so eingeben. Linux unterscheidet Gross- und Kleinbuchstaben.

    cat /proc/asound/Cards ist nicht gleich cat /proc/asound/cards .

    Zum Verständnis: cat ist das Kommando zum Ausgeben einer Datei auf der Konsole. Mit cat<Leerzeichen>/proc/asound/cards gibst du also den Inhalt der Textdatei "cards" in dem Verzeichnis /proc/asound auf der Konsole (=etwa die Eingabeaufforderung bei Windows) aus.

    Einfach nochmal eintippen.

    73 de Martin

  • So, das Leerzeichen hatte ich nicht.

    0 [Headphones] : bcm2835_headpho - bcm2835 Headphones

    bcm2835 Headphomes

    1 [Devics] : USB-Audio - USB Audio Device

    GeneralPlus USB Audio Device at usb-0000:01:00.0-1.3, full speed


    Danach müsste er den USB-Audio Device sehen, aber im Setup sind die Zeilen leer.


    Wenn ich den Befehl

    speaker-test -t sine -f 440 -c 2 -s 1<br>eingebe erscheint im Lautsprecher, der an der Klinkenbuchse ist ein Ton.


    Was auch nicht geht ist die Verbindung mit dem Pluto, der über LAN angeschlossen ist. Also kein Spektrum. Mit dem PC geht alles Problemlos.


    Gruß Ulrich

  • Da fällt mir noch ein, Du benötigst noch pulseaudio

    Code
    sudo apt-get install pulseaudio

    Kurt hat das in den Wiki Konfigurationstips mit angegeben.

    Dem Pluto musst Du eine feste IP zuweisen und in den Setupeinstellungen des SDR eintragen. Hat Kurt im Wiki auch gut beschrieben. Wenn es gar nicht läuft, versuch es doch mal mit seinem Image

    https://www.dj0abr.de/files/qo100trx_rpi_buster_armhf.img.gz

    Das funktioniert , musst nur noch die Adresse für den Pluto eintragen und die Soundkarte auswählen. Pulseaudio ist installiert.

    73 de Jens

  • Hallo Jens,

    pulseaudio hatte ich drin, IP ist eine feste im Pluto, Rasp 4 mit 4GB, 32 GB Karte, SSH eingeschaltet, aktuelle Raspi SW.

    Ich bekomme keine Verbindung mit dem Pluto.


    Das Image habe ich runter geladen ist aber nicht lauffähig. Hatte ich auch schon mal gemacht.


    Hast Du noc eine gut Idee??


    Gruß Ulrich

  • Hallo Ulrich,


    hast Du beachtet, dass das Image von Kurt noch mit Gnuzip gepackt ist? Du musst es also unbedingt entpacken (mit Winrar oder 7zip o.ä.) um an die .img Datei zu kommen. Das "gemeine" ist nämlich, dass der win32diskimager die gepackte Datei auch verarbeiten will bzw. kann, dass klappt aber nicht!!! Er schreibt eine Karte die nicht ausführbar ist. Das ist mir anfangs auch passiert, da ich gar nicht auf die Dateiendung geachtet habe. Also erst entpacken (dadurch wird das Archiv (2GB) auf über 6GB entpackt und dann mit win32diskimager (im Administratormodus) auf die Karte schreiben. Bei mir hat es dann auf Anhieb funktioniert.

    Die Monitorauflösung erkennt das BS automatisch, im SDR-Programm kannst Du dann den Monitor durch klick auf das linke obere Symbol (Computermonitor) für Deine Auflösung anpassen.

  • Hallo!

    Habe die Version 1.67 installiert und das Headset wird erkannt, sowei, so gut.

    Der Pluto wird als Wechselplatte erkannt.

    Aber:

    Sobald man die Software startet, beendet sie sich mit der Fehlermeldung :

    No Pluto found on USB, obwohl angeschlossen.

    Weiss jemand Rat?

    Vy 73 de Bernd, DL4ZAB

  • Hallo Zusammen,

    ich habe fast das Gefühl das in der SW 1.67 einige Treiber fehlen.

    Ich verwende folgende HW.

    Raspi 4 mit 4GB, 32Gb SD-Karte, orginal Raspi 7“ Display 800x480, USB-Sound, BL-Tastatur, Mouse per.Stick. Der Parameter SSH ist aktiv.


    Mit der „BATC SW“ funktioniert Langstone und Portsdown einwandfrei.

    Ich gehe mal davon aus das die HW ok ist.


    Das QO100 Image habe ich mit zwei verschiedenen Entpackern gemacht und es kommt immer ca. 6,8Gb raus. Anschließend mit zwei verschiedenen Image schreiben auf die SD-Karte gebracht. Als vier Varianten die nicht gehen warum auch immer.


    Dann habe ich das aktuell Image von der Raspi Seite geladen und aktualisiert. Anschließend die SW QO100 so installiert.

    Code
    wget https://raw.githubusercontent.com/dj0abr/QO100_Transceiver/main/install
    chmod 755 install
    ./install

    ging ohne Fehlermeldung.


    Man sollte laut Wiki mit dem Befehl „iio_info -s“ den Pluto sehen können. Es kommt aber die Fehlermeldung „Kommando nicht gefunden“. Geht also auch nicht wie Beschreiben.


    Das Prog. Pulseaudio wurde geladen.

    Die 'USB-Soundstick kann man im Raspi testen und alles geht. Nur das Prog. QO100 sieht nichts.

    Wenn man also das QO100 Prog. startet ist folgendes.

    Im dem „Menü Mixer“ kann man die USB-Soundstick sehen aber im „Menü Setup“ ist sie nicht zu sehen.

    Im „Menü Setup“ kann man IP-Adresse vom Pluto einstellen aber man bekommt keinen Kontakt mit dem Pluto.

    Wenn man den Pluto per. USB anschließt, eben fals kein Kontakt. Also funktioniert auch nicht.

    Das Laufwerk im Raspi vom Pluto kann man Raspi sehen, lesen und schreiben.


    Jetzt bin ich mit meinem Latein am Ende. Hat jemand noch eine gute Idee????


    73 Ulrich

  • Code
    wget https://raw.githubusercontent.com/dj0abr/QO100_Transceiver/main/install
    chmod 755 install
    ./install

    ging ohne Fehlermeldung.

    Bist du sicher, dass es ohne Fehlermeldung ging ? Hat die Installation nicht abgebrochen mit: Kann das Desktop-Icon nicht erstellen oder sowas ähnliches ? Ich habe mich auch ein paar Tage damit rumgeärgert und denke der Installer der 1.67 (bzw. ein script dahinter) ist fehlerhaft weil er nur die Häfte installiert.


    Wenn man also auf einem frischen Image den Installer ausführt, werden zwar grundlegende Teile der Software installiert aber nicht alles. Bei mir äussert es sich dann so, dass man das Programm zwar starten kann aber es erscheint nichts in den Fenstern (Wasserfall) und auch die Audio-Devices sind einfach völlig leer obwohl der Mixer sie findet. Der Pluto wird gar nicht angesprochen, nicht über USB oder Ethernet obwohl pingbar.


    Die Version vom März mit dem QO100_Transceiver schon drauf funktioniert, aber NUR die version in dem 500er Verzeichnis. Da die Version aber schon älter ist und man die Fenstergröße nicht ändern kann ist das unpraktisch bei einem 800x480er Bildschirm. Was ich dann gemacht habe: Das Verzeichnis QO100_Transceiver umbenannt auf z.B. QO100_Transceiver_600 und dann auf diesem Image nochmal die Installation wie beschrieben ausgeführt, die dann wieder abbricht. Dann die qo100trx.exe aus dieser Installation in das 500er /Release Verzeichnis kopieren. Das "neue" QO100_Transceiver Verzeichnis in irgendwas umbenennen und das 500er in QO100_Transceiver. Dann wird beim Start zwar rumgemault wegen verschiedener Serials, aber die Software startet, erkennt die Audio-Devices und auch den Pluto per USB.


    Ein OM (DL1ZAX) gab mir dann direkt auf QO100 einen Tipp. In dem Script prepare_raspi fehlt eine Pfadangabe. Das Script kann man aber nur ändern wenn man schon eine "fehlerhafte" Installation hat weil es vorher nicht existent ist.

    In dem Fall also ein neues Image oder das fertige vom März nehmen. Die QO100_Transceiver Verzeichnisse (wenn vorhanden) wieder umbenennen und dann wieder den Installer ausführen. Der bricht dann wieder bei der Erstellung vom Desktop Icon ab


    Raspberry OS found, install desktop starter icon

    cp: der Aufruf von stat für 'scripts/qo100trx.desktop' ist nicht möglich: Datei oder Verzeichnis nicht gefunden


    Jetzt in das Verzeichnis QO100_Transceiver/scripts und dort die prepare_raspi wie folgt ergänzen:


    aus: cp scripts/qo100trx.desktop /home/pi/Desktop

    wird: cp ~/QO100_Transceiver/scripts/qo100trx.desktop /home/pi/Desktop


    dann speichern und den Installer nochmal laufen lassen. Jetzt dauert die Installation auch deutlich länger und es werden noch etliche Teile hinzugefügt.


    Danach hat es dann auch bei mir mit der 1.67 funktioniert (Pluto mit USB angeschlossen). Ich habe die Installation auf dem Image vom März mit den bestehenden Installationen durchgeführt weil ich keine Lust hatte wieder ein neues Image zu erstellen ;-)


    73

    Bernd

    DK5BM


    PS: mit Linux kenne ich mich gar nicht aus, aber vielleicht hilft es dem einen oder anderen bis das gefixt ist. Und ja, die iio_info -s ging bei mir auch nur auf dem fertigen Image, nicht aber auf einem frischen, aktuellen.

  • Bitte Fehlermeldungen (auch) in Kurt DJ0ABR's Github als "issue" melden und dort nachverfolgen:



    https://github.com/dj0abr/QO100_Transceiver/issues


    letzte Meldung von heute dort:

    19.7.2021 ... the installation script was updated after some problems with libraries. If you had problems installing 1.67, then delete all previous files from your harddisk and make a fresh installation.


    73s Peter

  • Hallo zusammen,

    habe nun mit der neuen Installation die Sache weitgehend zur Funktion gebracht.

    Pluto erkannt, Wasserfall da.

    Was nicht funktioniert, ist das Ansprechen des PTT-Relais im Pluto bei Betätigung des PTT-Buttons, ferner ist det Mute-Button ohne Funktion.

    73 de Bernd, DL4ZAB