Posts by dg0opk

    Hi Peter

    many thanks ...this looks very interesting....


    So i hope that SPACEX will accept the RULES of the other KU band USERS .... TV SATs and so on....


    The REGTP (corr. Bundesnetzagentur) has only given a time limitied LICENCE for SPACEX in DL until now...

    WE WILL SEE ....


    73 de DG0OPK

    Well that was interesting. I tried to help and Mike immediately took offence. I don't know why and a pity as we might have made progress, but 73 and hope you get it working.


    Mike

    @Mike G0MJW

    i think the forum is not right place to discuss personal differences ...

    if you want to discuss some things .. maybe contact me directly via e-mail (info on my web page) or use the discussion mode in the forum....


    WAITING FOR RESPONSE


    THANK YOU & 73 de DG0OPK

    I am however curious and interested in your tests directly on OBS to understand how your pc behaves with libx265

    Hallo (agn)...


    i testet your libx265 information directly from OBS...and switched back to the script....(WINDOWS)

    LINUX (tested before, dec2020)

    other tests:

    INTEL QSV.... test on I7-7700T (LINUX) FULL HD ... on my YT

    INTEL QSV on RYZEN5 (via software emulation mode .... not working on HW suport because of AMD CPU).... not good but it workes


    update:
    AMF_H265 also testet ... looks working but no picture in MiniTioune or VLC ....

    AMF_H264 also testet ... PICTURE in Minitioune is OK and GOOD and in VLC corruptet in LIVE (MT) but OK on TS record replay in VLC



    73 de dg0opk

    Hallo Roberto,


    it workes good enough for me .... 1280x720 and SR333/500 Datarate from 80kbit/s -1.3Mbit/s

    (but if i need more I can use the NVIDIA P400 if i want) ...


    NOTE: for a normal DATV QSO we do not NEED FULL HD OR? , lowering the delay would be the goal !


    MY TESTS can be seen on my YT Channel (will be updatet sporadicly)


    https://www.youtube.com/channel/UCZyjrcCis9ZVCrR4hezntzQ


    73 Mike dg0opk

    Hallo all...


    many thanks to Roberto IS0GRB for this information.... i will also publish the informations about my tests in the last months with libx265 H265 encoder for the use with OBS on Windows and Linux.

    So this is without the use of an NVIDIA GPU Card for transmitting H265.


    Note before: (please read)
    You need a modern computer with good CPU to run the software encoder libx265.

    On my Ryzen 3 i could run upto 1280x720x15 in Windows. (with other applications beside e.g. Minitioune RX)
    On my Ryzen 5 i could run upto 1920x180x25 in Windows (but this is the CPU limit)
    On Linux 1280x720x25 is possible on a Core I7-7700T (low power CPU).


    SETUP for WINDOWS:

    On windows you have to install the (old) additional virtual camera plugin


    https://github.com/Fenrirthviti/obs-virtual-cam/releases


    Note: the build in virtual camera in OBS 26 or higher did not work for me....
    The used plugin can be found under TOOLS, VIRTUAL CAM and then select OBS-CAMERA


    The you have to download ffmpeg unzip all files and put it an an directory you want maybe c:\ffmpeg\

    Edit the attached script for your used parameters ...pluto ip.... TS rate and so on.

    Rename the script to an bat_file so that you can run it from command line.

    After activating the virtual camera you can start the attached OBS_TS_to_Pluto_DG0OPK.bat

    In the command window you can see some messages and other debuginformation.

    If all is running right you can look in the Pluto analysis window and go to TX if all is ok.


    SETUP for LINUX (tested with UbuntuMate 20.04):

    In linux you can use libx265 in OBS directly if ffmpeg is installed. Settings are under record and videoencoder libx265.
    The output setting is similar like written from Roberto IS0GRB.


    An alternative way ist also the use of an external script for linux with the virtual camera.

    I wrote me an script for this purpose which you can use the build in virtual camera button on OBS 26 or higher.
    Before starting you have to activate the virtual camera in the OBS GUI.


    Note: depending on your setup you have to modify the device names in the scripts. Refer to google or other searching machine howto find out your device names for audio uand video devices in linux.


    Attached an sample script for linux....which i have used for TS-Rate of 480kbit/s.

    rename OBS_TS_to_pluto_linux.sh it to an .sh and make it runnable before.


    If all is running right you can look in the Pluto analysis window and go to TX if all is ok.


    I hope it helps to others ...


    73 de Mike dg0opk

    Hallo,
    I have also finshed first tests last week and got about same results. 60W DATV at 30V/10A. Now waiting for a bigger power supply. There is no tuning necessary. About 15 dB of gain at 2406 MHz. Maximum gain is around 2350 MHz, but only 1 -2 dB more. These pallets do have a nice PTT design. There seems to be a temperature switch on the pallet also, but I have not tested it yet. I have used a 4 mm copper plate for heat distribution and a heatsink with blower.
    My pallets seem to be B-ware, but obvisiously have never been used. There are markers on the back pointing maybe to a point with lack of soldering to the copper plate. So far no problem.
    I am now going to construct a PA with two of these pallets to get about 120W DATV out for my small 1,2m dish.
    There was another sale on eBay, but with a pallet for 2500 - 2600 GHz. Also ordered one to see the difference.
    73 de Gerhard OE3GBB

    Hallo Gerhard....


    yes a really nice and good information from you.... for the gate current power down there are analogue switches STG719 which maybe can be used for PTT with external logical level... i have not tried until now ...but it looks very interesting . I am using on the AB side about 500-600mA idle current and for the PEAK amp gate is set to 0.7V nearly like the information given in the datasheet.

    Power Out in DATV reaches about 50-60W at 30V @ 8A , a bit more going upto 10A in DATV means about 75W without problem.

    Tested the amp only on short time until 12.5A that gives 100W+ out ...maybe more is possible but maybe out of spec and out of DATV linearity. So i think 75W is the max for our amateur radio use.


    NOTE: The DESIGN looks very narrowband so other version will maybe not work good.


    THANK YOU AGAIN for your information


    73 de dg0opk

    Interesting new amplifier pallets at ebay. Did someone use those allready? I have ordered 3 of them to test.
    https://www.ebay.de/itm/A3T23H…id=p2047675.c100752.m1982

    73
    Gerhard

    Hallo ....


    i ordered also this module in Nov 2020 and got it running, without modifications using a small heatsink with 2 fans.

    Testet the AMP in DATV with upto 75W now... and all looks ok and working stable and is very linear.


    Test on CW PEAK @ 120W out burned an capacitor on the DC Line on the PCB but i could repair it. Transistor survived.


    73 de dg0opk

    Hallo ...


    i made an short (cutted) video of the reception test.... on 27.10.2020


    DL0SHF sometime audiable in speaker/headphones


    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.


    73 de michael dg0opk

    Hallo all..


    i had the same problem in past with low modulation level using a simple SKYPE USB HEADSET with an Soundcard inside.


    The max. Digital Gain in SDR Console is a bit to low....


    so i tried


    EQUALIZER APO to add a bit of MIC GAIN to the mic in the headset and maybe to use some additional EQUALIZER


    https://sourceforge.net/projects/equalizerapo/


    Not easy to configure and install and had also some trouble with other soundevices at first , but i got it working


    73 de dg0opk

    Hallo ...

    made an other screenshot this morning from the "simple pluto analyzer" with 10MSPs on GNURADIO 3.8.1 Ubuntu 20.04


    RX: 80cm DISH, LNB-LO 9.388 MHz (TCXO) H-pol, IF 1105 in CENTER, AVERAGE and MAXHOLD ....


    you can nicely see the sigs of both transponders , NB is relatively weak because of polarisation loss V->H


    So the next time not to much time anymore ... "playing a bit"


    73 de dg0opk

    Hallo ...


    after some recherche in the WEB the Pluto is running now...with upto 60MHZ BW in Spektrum mode (-no decode mode) ...

    (decode of signlas is only possible with lower samplerate and BW < 5MHz because of USB2.0)


    the solution:

    you have to put in the following line in your .bashrc file


    export PYTHONPATH=$PYTONPATH:/usr/local/lib/python3/dist-packages


    after then you can start the gnuradio-companion from terminal.


    (It looks it is a bug in Gnuradio 3.8.1 or later and will maybe solved in the future)


    73 de dg0opk

    This THREAD


    is quiet since some month.... (i dont know why) ....


    With DVB-S2 it is possible to send IP DATA to the full footprint....


    i tested my system with 120cm RX/TX and i saw 3Mbit/s in fullduplex mode uplink/downlink....with my own signal (DVB-S2 Mode VIDEO)


    Maybe IP over DVB-2 is not interesting for radio amateurs? (more for the commercial ones?)


    an idea to get some more for an RX .... with low money system can be found maybe here....


    https://www.heise.de/news/Def-…ter-300-Euro-4865615.html


    Edit: maybe there it is any possibble to get the ip stream also from the MiniTiouner RX? maybe also as interface for other applications like ...plutosdr for TX or plutosdr as fullduplex data transmitter???


    an IDEA also for MAKRO92???


    73 de dg0opk

    Hallo ...


    if you are using the right WIFI-Modules with higher Bandwith 802.11n or better 802.11ac it will be no problem ....


    Like i Wrote


    "giving me 80Mbit in full duplex with low delay ..no problem with Pluto SDR in NB (SDR Console) and DATV"


    73 de michael dg0opk

    Hi,

    Finally I rollback as drivers are not ready yet for most devices. I will like to use Python3 for GNURadio but ...

    Hallo George ...


    installed Ubuntu20.04 now on my Linux machine.... Pluto wit IIO-Oscillocope worked ok and and modules compiled like given in the info from analog devices ....


    BUT:

    I cannot get running Pluto with Gnuradio 3.8.1.... IIO and Pluto block are inside GRC

    getting an error when starting the simple flowgraph... something si missing i think...


    this did not help .... export PYTHONPATH=$PYTHONPATH:/usr/lib/python3/dist-packages


    ----------------------------------------------------------------------------------------

    Generating: '/home/michael/gnuradio/plutotest.py'


    Executing: /usr/bin/python3 -u /home/michael/gnuradio/plutotest.py


    Traceback (most recent call last):

    File "/home/michael/gnuradio/plutotest.py", line 33, in <module>

    import iio

    ModuleNotFoundError: No module named 'iio'


    >>> Done (return code 1)

    ----------------------------------------------------------------------------------------------


    ANY IDEA ???


    Thank You

    73 de Michael dg0opk

    You're right, I know a few other people on our planet Earth, who would be better sent to Mars first, or better just pass Mars. :-)

    I'll be back!

    Danke PETER ... (dass Du "back" sein wirst)


    ich glaube auf der ERDE wirst Du noch gebraucht.... (für weitere projekte?)


    73 de dg0opk

    Hallo ...

    i am using a WIFI Bridge... (6cm) ...since one year now...

    no problem detected until now... worked like a charm and like on the cable connected LAN....


    edit: giving me 80Mbit in full duplex with low delay ..no problemn with Pluto SDR in NB (SDR Console) and DATV


    73 de dg0opk