Posts by DL3DCW

    - Kannst Du das "träge" Verhalten mal etwas genauer beschreiben?

    - Wie hoch ist deine CPU-Auslastung nur mit GQRX (in %)?

    - Um wieviel Prozent steigt die CPU-Auslastung wenn Du dann SatControl startest?


    Bitte die GQRX-Settings dabei im Originalzustand belassen! Denn diese Einstellungen FFT etc. wirken sich sehr stark auf die CPU-Auslastung aus. Die Originaleinstellungen des Images sind speziell an den Raspberry angepasst.


    Auf meinem System steigt die CPU-Auslastung nach dem Start von SatControl um nicht mehr als 5%. Somit liege ich insgesamt bei etwa 45%. Und damit läuft alles sehr flüssig.


    Ebenfalls wichtig: Der Raspberry Pi 4 muss unbedingt gekühlt werden! Sonst taktet er sehr schnell herunter.

    Ich habe mal den UP-Konverter abschaltbar gemacht (Set/Setup/Hardware/Up converter=none). Vielleicht ist das der Grund für die "Trägheit" des Programmes bei Dir. Es sind auch noch ein paar andere Verbesserungen eingebaut.


    Update auf die aktuelle SatControl-Version ohne neues Image:


    cd ~/SatControl

    rm *

    wget http://www.satcontrol.de/files/satcontrol.zip

    unzip satcontrol.zip

    rm satcontrol.zip


    Eventuell vorher die satcontrol.ini in ein anderes Verzeichnis sichern und anschließend zurück kopieren.

    Wenn GQRX und SatControl laufen habe ich eine CPU-Auslastung von etwa 40-45%. Am meisten davon braucht GQRX. Trotzdem ist alles sehr flüssig. Sogar per Remotedesktop via VNC aus der Ferne. Und parallel dazu auch noch Fldigi ... ;-)


    Mit dem CT-62 und SCU-17 geht es - aber ohne Modifikation hast Du keine PTT-Erkennung. Denn diese erfolgt über die CTS-Leitung welche beim CT-62 leider nicht angeschlossen ist.


    Der TX-Offset lässt sich unter Set/Setup/Offsets einstellen. Tipp: Das Set-Menü ist auch mit Mausklick rechts im SatControl-Fenster zu erreichen.


    In der INI-Datei steht der TX-Offset natürlich auch:


    [tx]

    df = 0

    Ok, perfekt. Habe das Programm bisher noch nie mit einem anderen bzw. ganz ohne UP-Konverter getestet.


    Die Frequenz Deines TX solle sich jetzt automatisch abhängig von der gewählten RX-Frequenz in GQRX nachstellen. Später muss Du nur noch den TX-Offset (fein)einstellen.

    Auf einem Raspberry Pi 4 sollte das SatControl flüssig laufen. Die Prozessorlast ist sehr gering.


    Alternativ in der INI-Datei (sudo nano ~/SatControl/satcontrol.ini):


    [up]

    lo = 1968000000


    Der Zoom bei GQRX wird nicht gespeichert. Da habe ich leider keinen Einfluss drauf.

    Zur Berechnung/Anzeige der IF wird die aktuelle LO-Frequenz automatisch aus dem UP-Konverter MKU2424 ausgelesen. Die LO-Frequenz kann unter Setup/Hardware/LO frequency geändert werden (z.B. LO=1968 MHz -> IF=432 MHz -> TX=2400 MHz). Dies wird dann auch im MKU2424 abgespeichert.

    Wurden nach dem ersten Start vielleicht die Desktopeinstellungen verändert? Denn wenn diese im entsprechenden Menü auf „Default“ gesetzt werden erscheint der originale Raspbian Desktop ...

    Auf den ersten Blick sehen die CAT-Kommandos von FT-817 und FT-897 identisch aus. Ich würde es einfach mal probieren. Kleinere Anpassungen kann man ja ggf. noch vornehmen. Ich selbst habe leider keinen FT-897 zum testen.

    Small hint: The default setting for the master frequency is now 10706 MHz (engineering beacon of Es'hail-2). Since this signal has the opposite polarization, it is not very strong. But it works well. The beacon is the left peak in the receiving spectrum (see screenshot below):