Posts by DL9SEC

    Hi Herko,


    as far as I see, you used a lot of solder for the reflector. The produced meniscus influences the resonance significantly.

    I had the same effect, removed the patch, used a file to remove the meniscus to get a right angle as good as possible and reinstalled the patch again.

    Try to use solder as less as possible. For a second POTY I used SMT solder paste, which gaves perfect results.


    73, Thorsten

    Hi Mike,


    I have a i7-3610QM CPU @ 2,3GHz 8GB RAM and only a few scenes in OBS (test pattern, image show, shack cam and one with an image film of the region here). "First-stage" H.264 encoding is hardware supported.

    Concerning the CPU load, it depends a bit what is fed from OBS to FFMPEG. I only work with 12 FPS and a low resolution, so FFMPEGs work is also not that much.


    Thanks for the hint with PCR/PTS. I could improve the stream quality by increasing that value.


    I have a big big playing field now with that solution and I will also try the lower bitrates. Saw SV8RV's transmission with SR66 and 8PSK. It's really amazing what is possible wit such a small bandwidth.


    I am really happy, that i can work the QO-100 WB transponder with my equipment. Works better than I expected :-D


    Thorsten

    Hi,


    the last weeks I played around with OBS, H.264 encoding and streaming via RTMP to my Pluto. Because of my limitations of RF power (about 20W) and dish size (about 73cm) I am bound to lower DATV bitrates (<=125kBit/s), but it works so far to send moving images via QO-100.


    Now that i saw what H.265 can do, I tried to get the "nvenc_hevc" encoder working in OBS, but it seems, that this set needs hardware support, which my NVIDIA GT650M can't offer. My expectation was, that in case of no HW support this encoder uses software encoding through "libx265" which FFMPEG should support. But it doesn't and OBS doesn't show a "libx265" selection in the dropdown (like the "libx264").


    A inquiry at the OBS forum wasn't succesfull, those guys live in their "4K-Twtich-Youtube" world and claimed, that H.265 software encoding will not work because of the CPU load (although i explained the background and that i want to use very low bitrates).


    Anyway, until my HDMI/H.265 encoder arrives from China, i searched and found a solution to create a H.265 encoded stream for the Pluto with software encoding. This solution works fine for me with SR125, a 384x306 image size with 12 FPS and 12kHz mono audio and i would say the quality is some kind of "crispy clear" compared to the same conditions encoded with H.264.


    What I use is:

    The FIRM2201RC gives the possibility to feed the Pluto with UDP packets (thanks to DD4YR for that hint) instead of the common RTMP streaming described on the Pluto documentation page. This UDP stream can be created in OBS by recording to an URL instead of a file. Unfortunately software encoding is only possible with H.264, but not with H.265.


    To work around this, the UDP stream is not sent to the Pluto directly, but to a local FFMPEG instance running which transcodes the stream from H.264 to H.265, downscales audio (thanks to G0MJW for the hint) and send another UDP stream to the Pluto.



    The FFMPEG instance runs in a console window here with the following parameters:


    ffmpeg -i "udp://localhost:7272" -vcodec libx265 -crf 33 -preset superfast -b:v 40k -acodec ac3_fixed -strict experimental -b:a 12k -ar 12000 -vf scale=384:-2:flags=lanczos -r 12 -f mpegts "udp://192.168.0.199:8282?pkt_size=1316"

    • -i "udp://localhost:7272"
      FFMPEG listens locally at port 7272 for UDP input
    • -vcodec libx265
      Selects the H.265 software encoder
    • -crf 33
      Selects the "Constant Rate Factor" for quality (the lower the better)
    • -preset superfast
      Selects the compression (the faster, the less delay, but the higher bitrate)
    • -b:v 40k
      Set video bitrate to 40 kbit/s
    • -acodec ac3_fixed
      Selects the AC3 audio encoder (more downscaling possibilities than AAC)
    • -strict experimental
      Seems to be needed for the AC3 encoder (don't know exactly why)
    • -b:a 12k
      Set audio bitrate to 12 kBit/s
    • -ar 12000
      Set the audio sample rate (corresponds to the bitrate)
    • -vf scale=384:-2:flags=lanczos
      Scale down the image to width 384 pixel, height is chosen automatically according to a parameter "n", use the "Lanczos" scaling filter (sharp)
    • -r 12
      Set output feamerate to 12 FPS
    • -f mpegts
      Use "MPEGTS" as output streaming container
    • "udp://192.168.0.199:8282?pkt_size=1316"
      Send the output as UDP to IP:PORT with given packet size (copied from Robert :) )

    I tried a lot of parameters for FFMPEG and also for OBS to get a good result and it wasn't always clear for me, why some combinations work and some not. The OBS settings can be found at the attachments. Also the Pluto transmit parameters I used ("PCR/PTS" and "PAT period" ar not really clear for me).


    Just start FFMPEG, then start RECORDING(!) (not streaming) in OBS and PTT ("Switch ON") at the Pluto.


    The H.265 output was really good via QO-100:


    CPU usage for OBS was about 5..7%, for FFMPEG about 3..5%


    The over-the-air stream is at its upper capacity level, but it works fine with my rig.

    Maybe there are some improvements and optimizations one can do and I would appreciate if they could be shared here...


    73, Thorsten

    You can send the audio and video to ffmpeg running on your PC and then forward the TS as UDP to the Pluto. That TS can contain anything you want.

    All no problem, if one knows how ;)


    In the meantime i managed to send an UDP stream, as Robert described, to my Pluto. Unfortunately i couldn't get a software encoder for H.265 in OBS, so i stuck to H.264, which leads to a stuttering audio with 32kbit/s. ;(

    But the audio bitrate can not be lower than 32kBit/s (no downscale option at the Pluto controller page)...

    How can we reduce the audio bitrate in OBS below 32kS? Would be interesting for RB-modes.

    Not in OBS directly, but via RTMP parameter at the Pluto (see attachment). Take a look at the Pluto's internal webpage, section "PC with Vmix or OBS".

    Actually the audio bitrate can be reduced far below 64kbit/s. I tried this down to 8 kbit/s, because i was short on bandwidth.

    Sound like though the phone, but sufficient... :D

    Morning Robert,


    thanks for the information.

    Ok, will try the beta (althought rtmp streaming seems to be broken).


    Unfortunately this HDMI-H.265 encoder seems to be rare and out if stock at ebay.

    Any ideas for further sources or alternative devices?


    With direct RTMP streaming from OBS to Pluto i can scale down audio e.g. to 8KBit/s (through the URL parameter).

    Can this be achieved with the UDP variant too?


    73, Thorsten

    Which firmware is necessary on the Pluto? Will the UDP streaming work with the latest release or is the beta ("for the brave") needed?


    If no HW acceleration is available for H.265, is there a software encoder available for OBS?


    DD4YR

    Thanks Robert for that desription, couldn't find this trick somewhere else.


    73, Thorsten

    Problem identified.


    I have VirtualBox installed on both PCs, the one where MiniTioune is running and the other where i want to receive the stream.

    On both i have to deactivate the "VirtualBox Host-Only Ethernet Adapter" to make the UDP stream transmission/reception work.


    One step further, now i can go ahead with the correct keywords at Google :-D ...

    Thanks Heiner.

    Read all that forum stuff down and up and up and down.

    Apart from that some descriptions don't work as written it seems (and some features are there, but not or insufficiently documented). The description above works fine locally on the PC which is running MiniTioune, but not on other workstations im my local network (but it should). The firewall rules in the Windows firewalls are looking fine as far as i can see.


    G0MJW

    Thanks Mike. Fritz!Box 7580 is forwarding IGMP.

    Morning Heiner,


    no, default was "TS_AddrUDP=230.0.0.10" here.

    As far as I understood, this is the multicast source address for MiniTioune.


    So every device at the network should be able to receive that stream in VLC with "udp://@230.0.0.10:1234", isn't it?

    Hi,


    I am using MiniTioune and its UDP multicast straming feature with the default parameters on a Win 10 PC.

    Receiving the stream on the same device works fine with VLC, but when i try to receive the stream on another PC at my network, nothing happens.

    Try to search the web for that problem, but can not find a solution.


    Is there something I am missing? Maybe something with the Windows firewall or so?

    Any ideas?


    Thanks in advance.


    73, Thorsten

    Ich habe nun einen LNB-Halter gefertigt der längs-und höhenverstellbar ist. Wenn es das WX am WE zulässt werde ich den Spiegel montieren. Btw: ich hab mich vertan, der Spiegel ist ein 90er (CAS 90), aber jeder cm zählt ;)

    Also der CAS80 hat 75cm und der CAS90 98,7cm (relevant ist die Breite).

    Wenn er 90cm Breite hat, ist es vermutlich kein CAS, sondern ein anderer Typ...

    DK1MHW

    Siehe hier: Dielektrische Linse für POTY und BaMaTech Feed


    Meine Erfahrung ist, dass der Fokuspunkt auf der Achse Richtung Sat bei der CAS80 nahezu unkritisch ist. Bei dem f/D (CAS80 0.66, CAS90 0.67) solltest Du ohnehin eine Linse verwenden.

    Ich konnte keinerlei sichtbare Verbesserung erreichen, indem ich den 10GHz-Eintritt in die selbe Ebene, wie beim Kathrein LNB brachte.


    Der Fokus sitzt knapp 10mm vor der Kante der Aluplatte.


    73, Thorsten

    Ich hatte Anfanfgs zuviel Zinn für die Lötung des Reflektors verwendet. Dadurch ergab sich ein schöner Meniskus in Richtung Patch, der jedoch für die Anpassung nicht gerade zuträglich war. Erst als ich diesen Meniskus nahezu rechtwinklig zurückgefeilt hatte, wurde es gut.


    73, Thorsten