PlutoSDR USB-OTG Broken, Help Please

  • I completed the ground modification due to constant ethernet disconnects and it worked briefly but then gave out. There are no lights on the ethernet adapter and no data throughput. The ethernet adapter has an approved chipset and works okay on other equipment.

    Connection via USB to SDR Console and SDR Angel is no longer working.

    The power only USB appears to be working as there is a pulsing blue light.

    I have removed the ground modification but it's still not working.

    I don't have any test equipment capable of detecting this fault. Is there a component that is prone to breaking under the ground modification that I can change?

    Any suggestions most welcome.

    Alan G0NQA

  • I expect you broke the tiny power chip. It can't be changed. If it is working with USB power via the power connector and USB data via the USB port then count yourself lucky and leave it like that. If not, have a look a the schematic to see how you can bypass it and feed 5V. That might work.


  • Hi Mike,

    There is voltage at the test points under the USB power connector only, but apart from the blue light flashing the Pluto is dead.

    Reset ZYNQ PG_1P3V measures 1.75V - all other test points are within spec.

    The issue is, there’s no power or data on the USB and data port.