Posts by OM3BD

    TX and red means that the FT-817 is in transmit mode. Otherwise there ist a green RX icon. The PTT state is detected by PTT GND signal from FT-817.


    Low state of CTS or DSR or DCD or RI from TTL/USB-Converter will be indicated as TX.

    Partial success today. I tried a third TTL/USB converter and finally the FT817 tx frequency changes when I change the rx frequency on the raspi!


    The only issue now is that the icon does not turn red on transmit. I tried connecting TX GND to CTS, DSR, and DCD, none made any difference, icon stays green on TX. I even tried directly grounding CTR, DSR, and DCD, still no red icon. But this issue does not seem very important. The only thing that changes when the raspi detects that the FT817 is transmitting is that the speaker is muted or the volume is lowered, correct? I can live without that.


    Odd that the icon always stayed red with one converter and now always stays green with the other.

    TX red = PTT active = FT-817 in TX mode

    TX green = PTT not active = FT-817 in RX mode


    If you press PTT on FT-817 color of TX icon changes from green to red.

    OK, I was confused because in your post #1 the icon was green RX (see attached), but I see you changed it to green TX in later versions.


    Guess I will have to try another cable. In the meantime, I'll have to use my laptop and SDR Console, which has better audio and spots from DX cluster on the waterfall, but I'd prefer to keep my laptop free for work purposes.


    73, Bill

    TX and red means that the FT-817 is in transmit mode. Otherwise there ist a green RX icon. The PTT state is detected by PTT GND signal from FT-817.


    Low state of CTS or DSR or DCD or RI from TTL/USB-Converter will be indicated as TX.

    So if it should be green RX during receive and red TX during transmit, what does green TX mean? I'm now seeing 432mhz in the IF QRG field (changes when RX frequency is changed) and a green TX icon.

    Try to desolder the wire TX GND and see what happens.

    Good idea, but unfortunately the connectors on the CT-62B cable are made of non-removable molded plastic. I can't get inside to desolder anything. Anyway, Frank says there is no TX GND internal connection on this cable.

    During TX (if the TX icon is red) there will be no frequency updates.

    That makes sense. Is there a way to stop the TX icon from going red? Maybe the pin that needs to be connected to TX GND is somehow permanently grounded, which would cause the raspi to think the FT817 is transmitting.

    You use the Yaesu CT-62 USB CAT cable? In this case the PTT detection will not work because the TX GND signal is not connected internal.


    So you have to use USB/TTL-converter with TX GND connected as described.

    Yes, I changed to a Yaesu CT-62 USB CAT cable. It just does not work with PTT? It should work to control the TX frequency on the FT817? It is not doing any control at all.


    Previously, I used the USB/TTL converter in post #192, which also did not work.

    Hi,

    in Post #200 , your converter is a silicon labs 2102, in post #206 it's a prolific. Are you sure you have checked the prolific with sdr-console or did you only verify that the silicon labs is working? Try the silicon labs under linux as well as the prolific under windows just to be sure.

    The converter in post #200 did not work with either the raspi or SDR Console on windows laptop. I changed cables, and the converter in post #206 works fine with SDR console but is not working with the raspi. There is apparently some type of communication, because I'm seeing 432mhz in the IF QRG field and a red TX icon. But the raspi is not changing the frequency on the FT817 and, even though the red TX icon means the FT817 is in transmit mode, it actually is in receive mode.

    "?" in the IF QRG field means that there is no communication to FT-817.

    Yes, that was my error, I had changed the baud rate. When I set it back to 4800 the 432mhz reappeared in the IF QRG field, and the icon changed back to red TX. But the FT817 was not actually in transmit mode.

    Hi,

    will it work if you tune the raspberry or the yaesu to the transponder frequency range (.489.500 - 490.000) ? Your photo shows both outside while uplink and downlink qrg do match. Maybe Frank inhibits TX if frequency is out of range? 73, Martin

    Good idea, thank you, but it is not working even in the transponder range.


    Working fine with SDR Console, maybe the CT-62 CAT cable is not Linux compatible?


    73, Bill

    TX and red means that the FT-817 is in transmit mode. Otherwise there ist a green RX icon. The PTT state is detected by PTT GND signal from FT-817.


    Low state of CTS or DSR or DCD or RI from TTL/USB-Converter will be indicated as TX.

    Thank you for the reply, Frank.


    The FT817 was not in transmit mode when the photo was taken.


    I just turned everything on, no changes from last night, but now the display is different. There is a green TX icon and the IF QRG box just has a "?", it no longer shows 432mhz. I clicked on Auto Tracking, no change.


    What could be wrong?


    73, Bill

    Yes, at FT-817 only the CAT rate of 4800 is important.

    Frank, I think I am close but I still need some help.


    It looks like my original problem was the CT-62 cable. I tried a different one and it is working to control the FT817 with my laptop and SDR Console. However, I am still not able to control the FT817 with the Raspberry and your program. I assume I must have some incorrect setting, as we know the cable and FT817 are OK, since control is working with the laptop.


    In the attached pictures, I see a red TX icon on the controller. On your screenshots, this icon is green and it says RX. Does that tell us anything? Otherwise, I think everything is set the way you instructed.


    What am I doing wrong?


    Thank you very much and 73,

    Bill

    Hello,


    I'm trying to set up my FT-817 for CAT control with SDR Console. I've followed the setup instructions at https://www.f5uii.net/en/contr…atellite-qo100-eshail2/9/


    The screen says the FT-817 is "online" and when I change the rx frequency a new tx frequency appears in the External Radio box, but the frequency on the FT-817 does not change at all.


    Any idea what may be wrong?


    Thanks and 73, Bill

    Also after restarting the program?

    Yes, I did restart, several times.


    I think it must be a problem with the cable or the USB/TTL converter or the FT-817, not the software. I tried using SDR Console and the result was the same: FT-817 "not responding". I have checked the cable with an ohm meter several times, all seems correct. The converter has a red LED that stays on non-stop, is that normal? And on the FT-817, the ONLY thing that needs to be done is to set the CAT rate on menu 14, correct?


    Thank you again, Frank, and 73,

    Bill

    The software uses 4800 baud default CAT rate. The USB port you can set under Setup/Hardware/Transmitter.

    Thank you for the reply, Frank.


    I've set the CAT rate to 4800 and set the Hardware/Transmitter to the correct USB port, but it is still not working. I've double checked all connections and believe they are correct:

    TX D pin to RXD on USB/TTL converter, RX D to TXD, TX GND to CTS, GND to GND.


    I must be doing something wrong, any suggestions?

    73, Bill

    In this version you can also use CTS. But it is a very very old version. I recommend to use Raspberry Pi 4B with last satcontrol software. There are many changes and improvements.

    Yes, perhaps soon I will buy a Raspberry 4, but for now I just have 3B.


    I made a cable from the DIN plug to the USB/TTL converter and connected everything as described. I set the CAT rate on the FT817 to 38,400. But it does not seem to be working, the program is not controlling the FT817. There is a red LED illuminated on the USB/TTL board.


    Are there some other settings I need to configure? I've never used a Raspberry before, but I know that on a Windows PC it is necessary to set the port, baud rate, etc., to make the CAT work.


    73, Bill

    Hello,

    I am operating successfully using a Raspberry and gqrx but would like to try SDR Console on Windows 10 laptop, using RTL-SDR hardware and SDR console 3.0.25.


    Following the instructions at https://www.sdr-radio.com/EsHail-2, I think I have set up SDR Console correctly, and I am seeing signals from QO-100. I was just wondering if it is possible to see the band plan on SDR Console, as with gqrx. The band plan on the screen is quite helpful.

    Thanks and 73,

    Bill OM3BD