SAT Controller SDR Nano

  • SAT Controller SDR Nano - CAT interface

    For connecting FT-817 (CAT/ACC socket) you can use USB/TTL converter below (CP2102). Very nice: All handshake signals are available. It also works fine as PTT output from a seperate digimode computer. For this only one external diode in series is required to connect DTR signal to PTT input (DATA socket) of FT-817.



    For fast PTT detection the signal TX GND from ACC socket can be connected to CTS input of the USB/serial adapter (because via serial CAT command there will be some delay):


    Hello,

    Could someone please advise me how to make the proper connections from my USB TTL converter (photo attached) to the ACC plug to the FT817? The pinouts on my converter are different from the ones in the devices posted by DL3DCW. If I understand correctly, the TXD pin on the converter goes to the RXD pin on the FT817 ACC plug, the RXD pin on converter goes to TXD on the FT817, and GND goes to GND. But what about CTS? My converter does not have a CTS pin, although there is a hole in the board labeled CTS. Am I supposed to solder a wire to the CTS hole and run it to TX GND on the FT817? Or something else?


    Thank you for helping and 73,

    Bill OM3BD

  • If it is possible then you can connect CTS to TX GND. But it is not absolutely necessary. The PTT signal from FT817 is also available via CAT command (you can enable this in the software). But via CAT the PTT detection is a little bit slower.

    Thank you, Frank. I can solder a wire to the CTS hole on the converter board.


    Did you determine it is better to use CTS than DCD? In post #17 above, you wrote, "Via USB/TTL converter (like CP2102) you can control transmitter (FT-817). For this connect RXD/TXD signals crossover and PTT GND output from CAT/ACC socket to DCD input of USB/TTL converter." But then in post #83 you suggested connecting to CTS.


    73, Bill

  • In this version you can also use CTS. But it is a very very old version. I recommend to use Raspberry Pi 4B with last satcontrol software. There are many changes and improvements.

    Yes, perhaps soon I will buy a Raspberry 4, but for now I just have 3B.


    I made a cable from the DIN plug to the USB/TTL converter and connected everything as described. I set the CAT rate on the FT817 to 38,400. But it does not seem to be working, the program is not controlling the FT817. There is a red LED illuminated on the USB/TTL board.


    Are there some other settings I need to configure? I've never used a Raspberry before, but I know that on a Windows PC it is necessary to set the port, baud rate, etc., to make the CAT work.


    73, Bill

  • The software uses 4800 baud default CAT rate. The USB port you can set under Setup/Hardware/Transmitter.

    Thank you for the reply, Frank.


    I've set the CAT rate to 4800 and set the Hardware/Transmitter to the correct USB port, but it is still not working. I've double checked all connections and believe they are correct:

    TX D pin to RXD on USB/TTL converter, RX D to TXD, TX GND to CTS, GND to GND.


    I must be doing something wrong, any suggestions?

    73, Bill

  • Also after restarting the program?

    Yes, I did restart, several times.


    I think it must be a problem with the cable or the USB/TTL converter or the FT-817, not the software. I tried using SDR Console and the result was the same: FT-817 "not responding". I have checked the cable with an ohm meter several times, all seems correct. The converter has a red LED that stays on non-stop, is that normal? And on the FT-817, the ONLY thing that needs to be done is to set the CAT rate on menu 14, correct?


    Thank you again, Frank, and 73,

    Bill

  • Yes, at FT-817 only the CAT rate of 4800 is important.

    Frank, I think I am close but I still need some help.


    It looks like my original problem was the CT-62 cable. I tried a different one and it is working to control the FT817 with my laptop and SDR Console. However, I am still not able to control the FT817 with the Raspberry and your program. I assume I must have some incorrect setting, as we know the cable and FT817 are OK, since control is working with the laptop.


    In the attached pictures, I see a red TX icon on the controller. On your screenshots, this icon is green and it says RX. Does that tell us anything? Otherwise, I think everything is set the way you instructed.


    What am I doing wrong?


    Thank you very much and 73,

    Bill

  • TX and red means that the FT-817 is in transmit mode. Otherwise there ist a green RX icon. The PTT state is detected by PTT GND signal from FT-817.


    Low state of CTS or DSR or DCD or RI from TTL/USB-Converter will be indicated as TX.

    Thank you for the reply, Frank.


    The FT817 was not in transmit mode when the photo was taken.


    I just turned everything on, no changes from last night, but now the display is different. There is a green TX icon and the IF QRG box just has a "?", it no longer shows 432mhz. I clicked on Auto Tracking, no change.


    What could be wrong?


    73, Bill

  • Hi,

    will it work if you tune the raspberry or the yaesu to the transponder frequency range (.489.500 - 490.000) ? Your photo shows both outside while uplink and downlink qrg do match. Maybe Frank inhibits TX if frequency is out of range? 73, Martin

    Good idea, thank you, but it is not working even in the transponder range.


    Working fine with SDR Console, maybe the CT-62 CAT cable is not Linux compatible?


    73, Bill

  • Well,

    you can check if raspberry recognizes the the cable by typing "lsusb | grep prolific" in a terminal. Your photo from an earlier post shows raspi can handle the cable. See entry "prolific 2303 on ttyUSB0" or so. Windows has driver problems with the prolific converters because of chinese fake chips and drivers refuse to work if the chip is fake, but linux doesn't care about that, it will work out of the box. So, no, your cable is not the culprit as far as the connection raspberry<>converter goes. Do you have an oscilloscope to check the other end of the converter that plugs into the yaesu? Are there signals detectable?


    EDIT: You said, it works with sdr-console, so the hardware should be fine .

    In a terminal, you can type "groups" to see if the user pi has permission to use tty , but if Frank put that wrong, this forum would be swamped with complaints.

    You may want to install a serial ports emulator on your raspi, set it to /dev/ttyUSB0 and baud rate 4800 to see if your radio talks to it.

    Feel free to ask for further help if that all is beyond your knowledge.

    All that given you are in a hurry and want to get to the bottom of things. Otherwise , wait for the advices Frank will give you for sure.

    73, Martin