Minitiouner Pro2 + Ryde + QO100 WebSDR

  • with WIndows 11, Microsoft is trying to drive us into a very strange situation. My PC at home is to be converted into a high-security machine, with restricted access for normal users. Maybe I'm not the only one who's worried about it.


    Anyway, that was the motivation to switch the whole shack to Linux. For the DATV reception I used the Windows-Minitiouner software. This has now been switched to Ryde and Raspi 4.


    And that move was much easier than expected. The BATC Ryde Software works out of the box, absolutely no tricks or fiddling required. Very good job BATC!


    To make tuning as easy as possible, I have included a link to Ryde in the QO100 WebSDR. Now it is possible to tune by mouse click in spectrum or waterfall. Since the WebSDR runs via browser, a smartphone can now also be used to remotely control Ryde, which is very convenient.

    The WebSDR allows up to 20 simultaneous browsers, so can be used on multiple PCs or phones in the home network at the same time, all of them can be used to tune ryde.


    Ryde is available at github:

    https://github.com/BritishAmateurTelevisionClub/ryde-build


    and the modified QO100 WebSDR:

    https://github.com/dj0abr/QO-100_SSB-WebSDR_DATV-WebSpectrum


    The WebSDR runs on the same Raspberry-4 as Ryde is running (or on another if you prefer)



    This picture shows a DATV reception via ryde, the WebSDR in the top right of the screen. The picture was just received by DL3MX using ryde and QO100 WebSDR.


    vy 73
    Kurt
    DJ0ABR

  • Hi,

    Port 80 is already in use here. Could not find where i can manually set the ports. Anyone?

    Once i had turned off the user of port 80 i got it to work anyway , but the delay is HUGE compared to RTL_TCP / sdr-console combo.

    My setup: RTL-SDR Stick on a linux-server doing many tasks on standard ports . That is why i need to change ports.

    73, Martin

  • Alright, alright...my fault..

    Found the SETUP Button on the Webserver in the upper right corner. It was not visible in the Browser window because the window was bigger than the screen. Now that i know it is there , i can configure everything to my needs.....

    73, Martin

  • Hi, now that the webserver / rtl-stick setup is running, i tried out the Ryde driver and MiniTiouner for the WB-Transponder.

    i have some issue with the screen on my raspberry. It seems, i receive the WB Transponder as i have audio, but the video seems so big, that only a grayish picture is visible. Where can i set the resolution?

    73, Martin

  • Hi Martin,

    same gray picture here, yesterday the Beacon was sending just a gray or yellow picture. Should be ok today.


    This is a block diagram of the setup:

    a DC block between LNB and Pluto is required. As I know Pluto does not have an input capacitor.


    The miniature TX transformer in one of my Plutos is broken. Does anybody know where to get a replacement?


    vy 73, Kurt, DJ0ABR

  • a DC block between LNB and Pluto is required. As I know Pluto does not have an input capacitor.

    Click: Available with 2 or more outputs, DC only goes from OUT to IN, not reverse


    Useful for single port lnb if you don't want to rx WB and NB simultaneously. The Minitiouner provides 14/18V.


    I have a 4-port lnb, so i use this device as a 3-way splitter on lnb Port 1 for all NB receivers like 2m-Downconverter (including 14V supply to lnb), RTL-Stick and experimental receivers. No danger to fry one of them. Port 2 is WB, Port 3 is 25MHz clock, Port 4 is terminated with 75 Ohm. This way i can rx NB and WB same time. No need to worry if there is DC on the output or not.

    73, Martin

  • I am a bit lost...

    Have ryde over one year and found this addition..

    I know my ways to my raspb... but have no qlue how i should install this..


    I have entered the command lines in the mentions file into my putty and although its doing a lot there is no webserver yet..

    I copied the github data into my rasp. but cannot start the scripts there...


    So little help for the starters would be appriciated..


    Benno

  • Benno,

    please describe what you achieved so far. When you start a browser on your windows-computer and type in the address of your raspberry, like 192.168.0.27/nb.html , what happens? Are there other programs occupying the rtl-stick or using port 80?

    73, Martin

  • Hi martin,


    I get

    Not Found

    The requested URL was not found on this server.

    Apache/2.4.38 (Raspbian) Server at 192.168.1.28 Port 80


    But thats not a supprice as i cannot start the server to config it at all...


    -bash: ./prepare_ubuntu_pluto: does not exsist...


    If i look in the script i can run the induvidual commands ..


    It seems i need a wget to get its out of the github into my running ryde..

    But there is the lacking knolledge..



    Benno

  • I think you failed to cd to the path where the software is located. After you did wget or git clone to fetch the software you need to type "cd QO< hit TAB to complete the path>" & Enter, this will change the directory . Then ./prepare_ubuntu_<your_choice> will run . Maybe you must make it executable with "chmod +x prepare_ubuntu_pluto" . By the way: Kurt failed to clarify this in the chapter "INSTALLATION" on github. Give me a shout on 10489.660 , my parking frequency.

    Edit: All prepare_ubuntu_***** scripts are executable already.

    By the way, the first thing i ALWAYS do on any linux i use is install the MidnightCommander sudo apt-get install mc.

    This saves you a lot of headache if you are an old fart like me and have worked with the NortonCommander under DOS back in the days

    :-)



    73, Martin

  • Go to your raspberry via ssh , then just type all those commands or copy & paste them.

    The command to download the software is


    wget github.com/dj0abr/QO-100_SSB-WebSDR_DATV-WebSpectrum.git


    or


    git clone github.com/dj0abr/QO-100_SSB-WebSDR_DATV-WebSpectrum.git

    you may need to put https:// before github


    then


    cd QO<TAB> & Enter to change into the directory


    then


    ./prepare_ubuntu or one of the other scripts


    The rest will work as shown on github. Please note that linux is case sensitive, thus


    ./prepare_ubuntu_pluto


    IS NOT


    ./prepare_ubuntu_PLUTO


    73, Martin

  • Tip: (with the help of martin...:))

    goto putty into the raspberry


    git clone https://github.com/dj0abr/QO-1…bSDR_DATV-WebSpectrum.git

    cd QO-100_SSB-WebSDR_DATV-WebSpectrum

    ./prepare_ubuntu_pluto

    ./build_RTLSDR

    sudo ./qo100websdr


    And than it should work...


    one question. I need to connect my pluto via USB to the ryde.

    If so, i cannot use the pluto for TX any more..

    Why not use the pluto via network..

    I succesfully used 1 pluto for DATV-TX and sdrconsole for RX via the network...


    So if the WB would use the pluto via network i may be able to use the TX. but we probably would get problems with 8 Mhz wide view..


    Looking forward to the next update...


    Thanks ..

    Benno


  • BTW,

    with "hit TAB" i really meant you should press TAB. This is one of the nicer things when working on the command line.

    cd QO<TAB> will complete the path to


    cd QO-100_SSB-WebSDR_DATV-WebSpectrum

    This also works on the windows command line, but we forgot how to use it.

    There you have it...