Multicast UDP reception with VLC

  • Hi,


    I am using MiniTioune and its UDP multicast straming feature with the default parameters on a Win 10 PC.

    Receiving the stream on the same device works fine with VLC, but when i try to receive the stream on another PC at my network, nothing happens.

    Try to search the web for that problem, but can not find a solution.


    Is there something I am missing? Maybe something with the Windows firewall or so?

    Any ideas?


    Thanks in advance.


    73, Thorsten

  • Morning Heiner,


    no, default was "TS_AddrUDP=230.0.0.10" here.

    As far as I understood, this is the multicast source address for MiniTioune.


    So every device at the network should be able to receive that stream in VLC with "udp://@230.0.0.10:1234", isn't it?

  • DL9SEC look here:

    Using MiniTioune with VLC

    You may find that some stations seem to have jerky video or poor intermittent sound and can be decoded more reliably with the open source VLC player.

    This is because MiniTioune uses the standard Windows demultiplexer to decode the audio and video and this is very critical on timing of the incoming signal.

    If the incoming signal is not strictly DVB compliant and has PCR or PTS errors (the PCR timing must be less than 500 nano seconds) the Window demultiplexer will not decode it properly and it has been found that VLC is more tolerant to errors.

    • To use VLC player on the same PC, edit the MiniTioune .ini file (found in the same directory as the MiniTioune program) as follows:
    Code
    1. ;=====================================================================
    2. ; adresse UDP / UDP address
    3. [UDP]
    4. ;=====================================================================
    5. AddrUDP=127.0.0.1
    6. Port=1234

    Note in Version V0.9beta8 the following line needs to be removed or commented out

    Code
    1. TS_AddrUDP=230.0.0.10

    Now launch VLC, go to Media > open network stream and enter udp://@127.0.0.1:1234 in the network URL box and press play.


    • To use VLC and a seperate device (PC, Media player, Raspbery PI etc) put the IP address of the player device in the MiniTiouner .ini file and then put udp://@:1234 in the VLC network address on the remote device.
  • Thanks Heiner.

    Read all that forum stuff down and up and up and down.

    Apart from that some descriptions don't work as written it seems (and some features are there, but not or insufficiently documented). The description above works fine locally on the PC which is running MiniTioune, but not on other workstations im my local network (but it should). The firewall rules in the Windows firewalls are looking fine as far as i can see.


    G0MJW

    Thanks Mike. Fritz!Box 7580 is forwarding IGMP.

  • DL9SEC Thorsten: here it works with the original settings in the cfg file:

    That is the part from cfg file:

    ;=====================================================================

    ; adresse UDP / UDP address

    [UDP]

    ;=====================================================================

    ; adresse UDP pour transférer le TS

    ; UDP address for TS transfer

    ;.....................................

    ; UDP address for TS

    TS_AddrUDP=230.0.0.10

    ; you can try a virtual address if you have no Ethernet or Wifi connexion

    ;TS_AddrUDP=127.0.0.1

    TS_Port=10000

    ; local IP used for sending the TS

    ; mettre ici l'IP que vous utilisez pour faire l'envoi : localIP

    ; cela sert dans le cas ou vous avez plusieurs réseaux locaux comme chez moi

    ; un réseau wifi pour Internet et un réseau local en ethernet

    ; NE METTRE QUE SI VOUS AVEZ BIEN VERIFIE VOTRE IP DE VOTRE CONNEXION RESEAU

    ;TS_LocalIP=192.168.1.55

    ;=====================================================================


    Then you enter into VLC on the other PC:

    UDP://@230.0.0.10:10000


    And then I see the stream here.

    Try it in this way.

  • Problem identified.


    I have VirtualBox installed on both PCs, the one where MiniTioune is running and the other where i want to receive the stream.

    On both i have to deactivate the "VirtualBox Host-Only Ethernet Adapter" to make the UDP stream transmission/reception work.


    One step further, now i can go ahead with the correct keywords at Google :-D ...

  • Hallo ...

    thank your for all the informations about here..


    i have same problem but i am using always more than one network card in the systems. They can not deactivatet easily.

    UDP is only working on local via loopback ip.


    Maybe anyone can give the information to F6DZP that he can look in the UDP bindings if there is more than network device.

    I have seen in past also other applications with this problem.


    More than one network device is common application in many systems.


    Nice sunday around

    73 de dg0opk

  • DL9SEC


    thank your for information but this is not my application... and the problem


    there are several other reasons and applications which need more than one NETWORK DEVICE...

    I think there is a problem maybe in the software


    (like i said before the binding of IP adresses to the devices have to recheckt)


    73 de dg0opk