PlutoSDR : Problem RX with last firmware by F5OEO

  • Hi

    I had a problem in RX with PlutoSDR last firmware of F5OEO ... does not receive .... restored the original firmware 0.31 everything works perfectly .... I redid the installation of the latest firmware of F5OEO and again no reception with SDR-Console ....

    Has happened to others?

  • Well it works for me. Things to check are how you connect. Perhaps do a search for the Pluto again. Make sure you have the latest IIO drivers installed etc. Make sure it's a recent version of SDRConsole. I could not get the Pluto to run on a PC that had not been updated in a while until I reloaded the Analog drivers.

    Proof - if needed.

    What might be different is I am accessing it via Ethernet rather than USB, but this should not matter.

  • Mike

    Thank you for your answer, but with the latest release of Évariste (beta_for_the_brave) SDR-console start and a few seconds later,... I get a big burst in the middle of the screen and disappears for a few seconds and starts again ........ it looks like a burst of RX calibration ... My configuration Pluto-usb to ethernet -HDMI Encoder ip - SDR -console 3.0.20

    I flashed the pluto with the previous version (from 22/01) and everything is fine.;)

    I am not the only one to have this problem .......

    73 Chris

  • That's very strange. I suggest you stick with the version that works for you and meanwhile speak to Evariste. There were several hardware revisions of the Pluto, mine is an earlier one, later ones had more memory. I am assuming you did the second CPU enable mod. You must have the latest drivers as well but I think you said you did. Your setup seems identical to mine - try it via USB in case your Ethernet adaptor is different?


  • Well, I've a similar problem. SDR-Console (V3.0.23 27.5.2020) does not work at all. It even crashes.

    1. Pluto - latest official FW, 70-6000MHz and 2nd CPU mod.

    2. F5OEO beta for the brave FW (Feb.2020)

    3. PTT HW mod from BATC done

    4. Ethernet adaptor USB3 with RTLsomething53

    DATV (what I want to use the pluto mainly for...) - works. Tested in the lab, 333kS, receiving with minitiouner. Stable. PTT

    works, but has to be toggled once after start of pluto. It starts always with transmitting but without putting the PTT relay on

    (another but different issue).

    So far, so good.

    Now a friend asked me for help using his pluto for SSB and SDR-Console (3.0.22 he uses). I tried to do what he did and failed.

    SDR console does not contact the pluto via ethernet. No reaction. I tried USB, did the search and the pluto was found.

    But starting the pluto via USB leads to a crash of the SDR-Console.

    OK. Then I took another fresh pluto out of the box, brand new, unmodified (HW+SW). Connected to the USB-Ethernet adaptor,

    played along with Console's settings and it works (tried 23cm).

    So there must be something related to the f5oeo firmware, may be some configs or drivers. But I don't know what.

    Who can help?

    Mike (G0MJW) wrote that it works for him. I'm confused now.

    Regards Mike (DL1GNM)

  • DL1GNM The Pluto with the F5OEO beta for the brave FW does not work with SDR Console. That was also the problem with Martin DL2GHM and his Pluto. After I reflashed to the F5OEO SW before the brave it works both. The NB and WB.

    The reason at the moment is unknow.

  • I found out meanwhile:

    The F5OEO FW stores information somewhere in the flash that is not overwritten by an FW update.

    I've a second pluto and FW beta 2020-02-05 works. The other -SDR-Console is not working pluto- was programmed again with

    1. analog devices original FW 0.31

    2. F5OEO firmware 20191220 (and it worked!!!)

    3. F5OEO firmware beta 20200205, and fails again to operate with SDR console.

    I checked the pluto.php site on my browser and found out that my individual settings (callsign) I did store

    to flash using the F5OEO firmware are still available. They survived all programming I did!

    So I assume that something is stored somewhere in the file system that causes the problems and crashes SDR-Console.

    Does someone know to reset the pluto to "factory defaults"? My search was not successful up to now.

  • Colin, no extras. Only the Pluto.

    But I was still having problems with stuttering.

    So I got the hint from dd9fj and dg9bfc to program the boot.frm (or dfu) file. This worked finally. Thanks! long I leave CALLSIGN and FREQUENCY on the pluto-datv-controller page untouched. It makes

    no sense to fill in those fields while operating on narrowband using SDR-Console. ;)

    Next I'll try to store CALLSIGN and FREQUENCY and use SDR-Console then.

  • Quote

    Next I'll try to store CALLSIGN and FREQUENCY and use SDR-Console then.

    No good idea. This causes problems. SDR-Console is stuttering. So I have to leave this open and will use those fields when I'm on DATV as workaround. It seams that there is a conflict between DATV and SDR-Console. Who sets the frequency??

  • No Mike, but if those fields are filled, SDR-Console does not work stable. So I leave it open and fill them only temporarily when using the Pluto as DATV transmitter. A reboot after DATV is necessary then.

    BTW: the beta-for-the-brave shows up as FIRM2101RC (Provider) when using RTMP. FIRM2201RC is shown when using UDP.

  • It's interesting that I do not have these problems, with the same firmware and the same software. My Pluto is connected via an internet adapter and is on my local subnet. I think you said yours was as well. Could it be something to do with the network configuration? Some switch perhaps?