Extender USB/LAN

  • Buona domanda :-)

    Hai una connessione 1: 1.

    Questa connessione non può usare la LAN esistente (credo) Con il mio adattatore utilizzo la LAN esistente e anche la rete WiFi.

    Il mio Pluto è a 50 metri dalla casa ed è collegato tramite WiFi.

    Non so se funziona con il tuo adattatore.

  • Good afternoon to all...

    Hmmmm extender have noting to do with changing the ip adress....(its not a usb to ethernet if) principal its a looooong usb cabel!!

    So in my opinion you must not change the pluto ip settings...

    But...pls dont forget to use the 5v maybay..i dont have testing thath...your usb signal (current) is to low @ the pluto site

    "OS independent for fast, hassle-free setup • Kit includes a local unit (transmitter) and a remote unit (receiver), as well as a universal power adapter (power adapter must be connected to the remote unit) "

    Depend on the distance of cabel....

    See for info

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Greetings and hope its helps you a little

  • Code
    come è risolto ... per favore soluzione

    come è risolte ??? per favore soluzione ...

    Come hai fatto a farlo funzionare ????

    Si è verificato un falso contatto sulla presa che alimentava l'Extender 5V. (Lato Plutone).

    Se ieri ha funzionato, non vedo perché non dovrebbe funzionare anche oggi!

    Alla fine l'ho fatto, grazie per il tuo interesse!

  • Thought IU2KAC wants the Pluto in his LAN. Then the hardware is the wrong one. Thats why i posted before, but now it looks that he just wanted to extend the USB, then its ok.

    About extender:

    I tested an extender too , bought it for the LimeSDR.

    It´s a direct connection like USB, but with an Network cable as extension .

    The Pluto/Lime or whatever isn´t available in the network like it is if connected via a USB / LAN Adapter to your local network, cause it isn´t in the network. (Lime does not support direct LAN)

    My adapter as passive (without 5V extern) and worked over 5m LAN cable without problems. Took a standard CAT7 cable between, without configuration and it works. While the LimeSDR supports USB3 and my adapter don´t , i stopped experimenting.

    In my opinion, on a Pluto, the USB/LAN solution makes more sense if you already have a LAN. Then the pluto is from everywhere available, from Smartphone, tablet, PC, notebook etc. Also if you have a "server" running or super fast internet, from the WAN. The bandwidth is massive it needs, don´t forget that.

    Maybe you wanna try USB/LAN with your pluto IU2KAC...

    sorry that i write in english. Also not my mother language but much better than my italiano :)

    Have a good time and stay safe!

  • A kind of USB extension can be realized with two USB-to-LAN adapters for the Pluto. This is then a simple peer-2-peer network with two fixed IP addresses.

    The advantage is that you always have full bandwidth, even if other family members stream UHD videos through the router ;-)

    On the PC side I use an "ASIX AX88179 USB 3.0 to Gigabit Ethernet Adapter". However, this type does not work reliably on my Pluto-USB-OTG, although it is classified as compatible by AD. But an "ASIX AX88772 USB2.0 to Fast Ethernet Adapter" does it without problems on the Pluto side.

  • Hello,

    looks like I need some help to get my Pluto in to my LAN Network.

    I did try serveral USB to LAN Adapter as well as some OTG Kabel and power supplyies .

    I played arround with the settings in the config but never had suggsess to get connection to the Pluto via my local LAN.

    When scanning the Network the IP given to the Pluto is shown as active in the Network - but there is no way to reach the Pluto .

    Even a simple PING to the Pluto IP from the Windows PC will not work - now answers .

    What is it I am doing wrong ?

    Just to make clear, it is not a direct Pluto to PC LAN conection I am looking for , I like to have the Pluto integrated into my local LAN to reach it from different PCs. LAN is under control of a Speedport W724.

  • The two IPs are the same and I think that's the problem.

    Here you should put a different IP.

    So in the program, for example SDR-Console, you will have to create two different configurations.

    One when you connect Adalm Pluto via USB ( IP ) and another configuration with the second IP (for example IP when you connect via LAN.

    Once the IP is changed in the USB_ETHERNET section of the config file

    just put in the browser the IP address you have configured (for example and you will see the welcome page of Adalm Pluto.

  • Team, maybe you can support/answer my question as well.
    I have the Pluto on USB and it works as it should. I connect the Pluto with LAN and RX worked fine but on TX I realize interruptions during sending e.g. a USB Tone with SDR-Console. No such interruptions during TX via USB.

    I checked it with the Pluto on the RX path.
    I am helpless and using the:

    UGREEN USB Netzwerkadapter USB 3.0 auf RJ45 Gigabit Ethernet Adapter für Macbook Ultrabook , Windows 10, 8.1, 8, 7, Vista, XP usw (Schwarz) which was suggested to use in a youtube video from US.

    Any idea or hint?


  • Hello,

    yes I had the same IP for USB and LAN in my screen shot - but be sure I did try with LAN IP as well.

    Same behaivar - When scanning my Network , Pluto IP can be seen as device - but simple PING to the IP gets now aswer

    does not matter what IP I give to the Pluto - or if I leave IP open in the config - and then use DHCP.

    73, Lutz

  • Hallo,

    I did a direct coupling with my first and also with the second Pluto. Both devices (host and client) need a fixed but different IP in the same adress range 192.168.1.xxx (example). The USB-Ethernet-Adapter is an ICY Box IB-AC510 with OTG.
    But the most important thing was to put the adress which is assigned to the Pluto in the standard gateway mask at the host PC. This was succesful with two total different PCs.
    Please note, this is not DHCP.

  • Hi Lutz,

    I was struggling with the same problem.

    With the following approach I was able to access the Pluto via my LAN:

    External Content www.youtube.com
    Content embedded from external sources will not be displayed without your consent.
    Through the activation of external content, you agree that personal data may be transferred to third party platforms. We have provided more information on this in our privacy policy.

    Hope that helps.



  • Avoid having your IP assigned by DHCP.

    DHCP could assign a different IP with each connection and you would never find your Adalm Pluto.

    To see if everything works just type in your browser the IP assigned according to your configuration.

    Once you have modified the "config.txt" file in Adalm Pluto, disconnect the power to your Modem / Router to make a "clean" restart of the various IPs.

    When everything is connected with the new configuration, restart your Modem / Router.

    Do a check as per attached photos.

    This page should appear in the browser

  • Hello,

    today I was playing around again - and for whatever reason - I was able to fix my problem !

    Only thing I did different today is to set the USB Network Connection in the Pluto to a more different IP - /

    While my LAN-Network stays at 192.168.2.xxx - first I try to set NO LAN-IP in the Pluto, meaning it will go for DHCP -- it worked !

    After that I gave a fix IP to the Pluto and it worked as well.

    Now I can run SATSAGEN and SDRConsole via Network .

    Thanks for pushing me to the right solution !!!!!

    73, Lutz

  • Hello......,

    it took me 14 days to get a Lan - Lan connection with the

    Get Pluto and the SDR console. Everything changing the IP addresses did not help - then I got more by accident the IP of the

    Entered USB to LAN adapter and I had a connect.

    I always saw the IP at ipconfig (169.254.63.XX).

    73 Jürgen

  • Hello

    I have a problem with a pluto from a friend that does not work correctly, it works in USB but not in ethernet, then once connected in DATV with OBS by looking at the video buffer analysis the level is still below zero, zero being its line of reff. , in the red !!! whatever the settings, I specify that my settings work with my personal pluto, the firmwares are 0.31 + that of F5OEO from 05-02-2020, I formatted the pluto and installed version 0.32 + new F5OEO version but nothing is wrong done, still no Ethernet access or correct operation with OBS, I saw by SSH that the hw_model_variant is 0 and mine is 1, it seems to me that there was a problem of compatibility with the versions 0, thanks for the answers even if it's not obvious.

    73 F4FDW Laurent

  • Hi Laurent

    Most of these Ethernet not working problems are due to the USB to Ethernet adaptor, either not being compatible or not getting sufficient power. The problem is adaptors that look identical might not have the same hardware inside. First thing to do is try another and the other thing to do is ensure it is powered and that normally means a Y cable or hub.